.NET does not apply on gridview in a published view

I am using a gridview with the following styling.
<RowStyle BackColor="#edf9cd" BorderWidth="2px" BorderStyle="Solid"
                                    ForeColor="Black"  />

When run through the ide locally the style is visible and each row gets the appropriate style.
When I view a published version it does not.  At first I thought there was an issue replacing the published files with newer ones but after deleting all the published folders, republishing and viewing the output source from the published site the styling is clearly visible and yet it does not render the styling.  Note: the styling is rendered inline so the fault does not relate to linking issues with CSS style sheets.

Any obvious reasons for this?
dgloverukAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

CimperialiCommented:
two thought:
1)
look at @Page directive and inside web config: if you ever applied a theme, you could have matter in overriding: standard themes override styles on the page, StyleSheet themes are overridden by styles on the page (look here for further reference: http://www.murraymac.net/70528/CustomizingWebApplications.aspx )
2)
look at generated html to see if there is anything that could make the style not working correctly (an invalid char somewhere for example) or that could override id (ie: a class selector you forgot you added somewhere in your serverside code)

a hint:
if nothin else works, try add  "display: table;" to the style for the gridview
0
dgloverukAuthor Commented:
No luck on those points.  I cleared out lots of CSS styles references to the header section.
I havn't applied a theme so could not find the @Page directive anywhere in the solution or the web config.
No invalid chars.
The code is being published with FULL delete on server side and I've deleted it manually myself just to be sure.  As stated the output HTML looks like it SHOULD work and carries the right style.

I tried the display:table; in the CCS but this also didn't work.

A little more that might give a clue... this is the webpage that is being output :
http://eweb.firstrecruitmentgroup.com/subway/qjump.aspx
as you can see the rowstyle DOES produce the border and so works.
However viewing this website through the intranet server page does not produce the border (even though the page has the same source files and is being served by the same server and is being viewed in the same browser).


thanks for your help so far.
0
CimperialiCommented:
>as you can see the rowstyle DOES produce the border and so works.
>However viewing this website through the intranet server page does not produce the border
>(even though the page has the same source files and is being served by the same server
>and is being viewed in the same browser

Wait. You already made it works, so it must be a difference between internet and intranet settings (probably not of your boewser but of the server itself). Could you ask to server Admins?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

dgloverukAuthor Commented:
I am the server admin :)

I am not aware of any settings which would affect this.

If it were a trust issue I would have expected it to have NOT viewed the CSS via the external address correctly as opposed to not viewing the internal view correctly.
0
CimperialiCommented:
http://stackoverflow.com/questions/1434020/aspx-page-renders-differently-when-reached-on-intranet-vs-internet
i forgot about the quirk mode and the meta http-equiv="X-UA-Compatible" content="IE=8"
see links. However, as you are admin, look also at the second suggestment, there...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dgloverukAuthor Commented:
This solved the problem!
Excellent job, that would have been a needle in a haystack for me.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
CSS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.