• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 358
  • Last Modified:

retaining permissions from server to server

I need to copy bunch of information from one server to another. It's a 2003 server to a 2008 server with NTFS permissions.  Is there a way for me to retain the current permissions so I don't have to redo it?
0
WellingtonIS
Asked:
WellingtonIS
  • 4
  • 2
1 Solution
 
Adam BrownSr Solutions ArchitectCommented:
Yeah. You can use Robocopy to do a mirrored copy from the Windows 2008 server. http://ss64.com/nt/robocopy.html has the command line syntax info.
0
 
the_endjinnCommented:
As long as the the permissions relate to domain users/groups rather than to local users/groups then doing a robocopy with the /copyall or /copy:DATS you will retain security. If it is a one time copy then I would recommend against using mirror unless you know what it does.

If the users/groups are local then you will probably have to export the permissions with icacls, modify any computer names and then import them on the new server when you have created the local users/groups with the same names.
0
 
WellingtonISAuthor Commented:
All accounts are domain accounts.  I'm in a middle of domain migration and rebuilding a server so some users are in the old domain and some in the new.  I need to retain the old so I can add the new.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
WellingtonISAuthor Commented:
Trying to run the command it's telling me the path can not be found???
ROBOCOPY\\welfs01\P_Share\*.*/s \\wrmsf01\P-Share
0
 
the_endjinnCommented:
Hi Wellington,

The syntax you have is wrong, please see below for the correct robocopy syntax for the above command.

robocopy <source> <destination> <files_to_copy> <options>

robocopy \\welfs01\P_Share\ \\wrmsf01\P-Share *.* /s
0
 
WellingtonISAuthor Commented:
Had to take out the *.* and just use /s but it worked thanks
0
 
WellingtonISAuthor Commented:
Thanks.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now