Exchange 2010 attachment size attachments maxed out

I did some research on how when I have a user send emails with attachments they get this error back and the email is undeliverable...

"This message wasn't delivered to anyone because it's too large. The limit is 9 MB. This message is 12 MB."

I used the link below and set the transportconfig to 40MB, the individual users max send/receive to 40MB. and even the send and receive connectors to 40MB.  I checked everything with EMS and anything that showed anything other than 40MB I changed...which was only 2 fields in the transportconfig.

I even modified the registry to change the update time from 2 hours to 20 minutes and restarted the Exchange Information Service.  Still the user is getting the same error.  What else could it be?  I'm thinking of restarting all the microsoft exchange services, but that's an off production thing.

Anyone have any ideas or anything I can check to see if I missed anything?  Also going through 200+ users to modify the whole organization max send/receive attachments is pointless if I have to go in every user right?

Any ideas would be great!

Thanks

http://exchangepedia.com/2007/09/exchange-server-2007-setting-message-size-limits.html
ecubenetworksAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ThorrssonCommented:
You wouldn't want to do it manually, but a simple foreach loop in powershell would cover each user much faster that you could :)
You may need to kick the transport service before it picks it up, there
Can you post a copy/paste of the message itself? there is an order of precedence in the limits and the one configured at the userlevel always wins (at least it is supposed to... yours doesn't seem to)
Are you running any anti-spam/virus on the server? are you routing through a smarthost or a edge server?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ecubenetworksAuthor Commented:
I do have anti-spam filter put on the hub transport since we have no edge transport.  I kicked the Exchange services this morning before I came in and will have a user test to see if they can send the file they want and will let you know.

Thanks
0
ecubenetworksAuthor Commented:
So rebooting and having the Exchange services restart didn't do the trick.  Here is the message the users get...

"Requested gave this error:
SMTPSEND.OverAdvertisedSize; message size exceeds fixed maximum size


This message is larger than the size limit for messages. Please make it smaller and try sending it again."

What is odd is the user sent this email to a bunch of people, and in house it went through.  But to the other site it doesn't.  So this tells me that it's the other end, but I made both ends max attach size at 40MB, but still get this ..."This message wasn't delivered to anyone because it's too large. The limit is 9 MB. This message is 12 MB."

Odd!!
0
ThorrssonCommented:
Where is the message coming from? is it an email, a popup or system message?
If you are set to 40mb everywhere it really should be 40mb unless one of the settings was missed.
most other mail servers won't accept 11mb let alone 40.. so i would think it may be a message from the remote server, but it entirely depends on how it is showing up :)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.