Excel 2007 won't open .xls files? Won't give Excel as an option?

I am configuring our first Lenovo X1 laptop for a VP.  It is running Windows 7 Pro (64 bit)

I removed the Office 2010 trial that came installed without activating it and have completely  installed Office 2007 Pro.  The install went without a hitch and I have ran service pack 3 and all of the available updates and patches.

I am having an issue with Excel not opening .xls files.  If I try to open it I get the pop-up to choose a program to use but Excel isn't an option.  Same results when I right-click change to/open with etc.  I also tried going through the control panel to the file options but got the same result.  

I can open the file from within Excel but if I save or close it I still can't get it to recongize the file format and open normally.

Does anybody have any suggestions on what might be causing this and/or how I manually browse to Excel to choose it to open the file with?
nhawkinsVAAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

redmondbCommented:
Hi, nhawkinsVA.

I don't know what's causing this, but you may be able to fix it by clicking on the "Browse" button in the "Open With" dialogue. Navigate to Excel.exe (somewhere like c:\Program Files\Microsoft Office\Office12), select that and click on "Open". Make sure that "Always use..." is ticked and hit "OK".

Regards,
Brian.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nhawkinsVAAuthor Commented:
I had tried that without any luck but tried again after your response and realized that I needed to go into Program Files x86 to find what I needed.

Huge Thanks!
redmondbCommented:
Thanks, nhawkinsVA - particularly for your feedback. I'm afraid I'm very 32-bit centric!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Office

From novice to tech pro — start learning today.