• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 830
  • Last Modified:

RPC over HTTP Not Working

I am having some major configuration issues in my new exchange 2010 environment.  I have exchange 2010 fresh install with majority of clients on office pro plus 2007.  I had a problem with them getting prompted for username and password.  I finally fixed that by getting the correct ssl cert for autodiscovery.  Now that that id fixed I am having a problem of RPC over HTTP not working.  When my users are in the office (Outlook 2007 or 2010) they connect up fine.  ONce they leave the office all they get is Trying to connect in the bottom right corner.  Will not connect up when you test connection from outlook icon.  Autodiscovery is working though.  I do not know what to do.

It also works just fine on the smartphones.

Any ideas??????
0
APWIP-Admin
Asked:
APWIP-Admin
5 Solutions
 
Getsum_BloodlustCommented:
could be the MTU... i have had issues like this before..

firstly, follow the instructions in this site on the remote machine...
http://help.expedient.com/broadband/mtu_ping_test.shtml

Once you have found the optimal MTU, follow this... in cmd
netsh interface ipv4 show interfaces

then

set subinterface "name" mtu=XXXX store=persistant

XXXX = ping test value + 24...
0
 
chakkoCommented:
Have you setup the Outlook Anywhere settings inside the Outlook program?

When you view the settings, click the More Settings Button.  Then on tab (I think 4th tab - Connection) there is a checkbox and button for making the settings.

I think it could be the case that your outlook profiles were setup before Auto-discovery.  So you need to setup the RPC/HTTPS (Outlook Anywhere) manually now.
0
 
Viral RathodConsultantCommented:
GO to https://www.testexchangeconnectivity.com/

Run "Outlook Anywhere (RPC over HTTP)" test and post the results.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Pavel NagaevLead email system administratorCommented:
Use www.testoutlookconnectivity.com for diagnostic problem. You will se¿ the connection procedure step by step and will see an error.
0
 
Pavel NagaevLead email system administratorCommented:
Of course https://www.testexchangeconnectivity.com/. I made mistake in previous post and unable to edit it. Sorry.
0
 
Alan HardistyCo-OwnerCommented:
What cert did you buy and what names does it include?

You will need:

mail.externaldomain.com
autodiscover.externaldomain.com
internalservername.internaldomain.local
internalservername

If you have those name (or variations of the same names), then you should be working happily, if not - then you got the wrong certificate.

The name you are using in your Proxy settings in Outlook needs to match a name in the SSL certificate otherwise it isn't going to work.
0
 
APWIP-AdminAuthor Commented:
I appreciate everyones help.  I ended up just rebooting the server and everything started working.  I am not sure if the restarting of IIS or the services fixed it but it is working again.  Once again thank you all for your help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

How do you know if your security is working?

Protecting your business doesn’t have to mean sifting through endless alerts and notifications. With WatchGuard Total Security Suite, you can feel confident that your business is secure, meaning you can get back to the things that have been sitting on your to-do list.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now