Cisco 3550 Switch Configuration

I am configuring a Cisco 3550 48 Port switch for a small office, and they dont have or need anything special. Now from a design perspective, I was thinking about what to beyond the basic configuration. So far I came up with shutting down unused ports, and setting up broadcast storm protection on each port (shut down at a certain level). Is there anything else you guys have found useful in your SMB setups?
LVL 4
Cobra25Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ipajonesCommented:
I would also do the following:

switchport mode access
spanning-tree portfast
spanning-tree bpduguard enable

--IJ
0
SouljaSenior Network EngineerCommented:
spanning-tree mode rapid-pvst



interface vlan 1
ip address x.x.x.x 255.x.x.x
no shut

ip default-gateway x.x.x.x
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Cobra25Author Commented:
can you guys explain how the spanning tree modes would help specifically.

I understand the vlan and ip info.
0
ON-DEMAND: 10 Easy Ways to Lose a Password

Learn about the methods that hackers use to lift real, working credentials from even the most security-savvy employees in this on-demand webinar. We cover the importance of multi-factor authentication and how these solutions can better protect your business!

SouljaSenior Network EngineerCommented:
You always want to have spanning tree enabled, and rapid is the improved version of spanning tree over the default mode of spanning tree that your switch will run. While you may only have one switch, there is always the possibility of someone plugging a dumb switch/hub at their desk into a port and then looping it somehow.
0
Cobra25Author Commented:
Soulja,

Do you know what threshold i should use for the broadcast storm control?
0
SouljaSenior Network EngineerCommented:
Honestly the threshold is up to you. Just make sure make sure you set both multicast and broadcast to equal thresholds and never have multicast lower than broadcast.
0
Cobra25Author Commented:
Do I need to put in a multicast threshold?
0
SouljaSenior Network EngineerCommented:
In your simple setup, I would just setup broadcast and maybe unicast storm control.
0
ipajonesCommented:
to explain these:

spanning-tree portfast
spanning-tree bpduguard enable

"portfast"  ensures that an access port (i.e. end-user port not a trunk) will transition directly to a spanning-tree forwarding state without waiting for the spanning-tree topology to fully converge.

"bpduguard" prevents a loop in the network from occuring in the case where a switch is connected to an access port using portfast.  Because the portfast doesn't wait for convergence to occur if another switch was connected to this port a loop could occur in the network.  If a port configured with bpduguard receives a bpdu from another switch the port is error disabled.

--IJ
0
Cobra25Author Commented:
For portfast, if i enable this and someone connects a switch to this port, would spanning-tree still detect this loop?

For bpduguard, would that shut a non-cisco or hp switch down (say an unmanaged netgear or dlink switch) i'm not sure if these switches send out bpdu's.
0
SouljaSenior Network EngineerCommented:
If someone plugs in a switch and you have Rapid PVST mode, the switch will detect the bpdu's coming into the port and will switch that port from and edge port (portfast) to a normal STP port. Plugging a switch into the port won't necessarily cause a loop, but the possibility is possible if the conditions are met.

If the switch doesn't send bpdu's then the port will not go err-disable.
0
ipajonesCommented:
For portfast, if i enable this and someone connects a switch to this port, would spanning-tree still detect this loop?

Not without bpduguard - that's what it's for

bpduguard applies to the local Cisco switch.
0
Cobra25Author Commented:
Thanks soulja. So do unmanaged dlink or netgear switches send out bpdus?
0
ipajonesCommented:
Thanks soulja. So do unmanaged dlink or netgear switches send out bpdus?

If the switch supports spanning tree it will send out bpdu's.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.