Brother MFC-8370DN NIC problem

Hi all,

This is my first time posting here so please bare with me.

We have a Brother MFC-8370DN, which is for another department, and we want to be able to connect it up to our network so that we can a) set up scanning via FTP and b) access the web interface, and c) maybe set up a printing queue if they want it. The problem is that I think the NIC is faulty.

What I have done so far is:
- use a network cable to connect to data point in the wall and connect it to my MacBook to see if I get a network connection, which I do get.
- use the same network cable to connect to the MFC, and have DHCP set as the network boot method
- turn the MFC off and on again to ensure that the IP address has changed
- log into our DHCP server to track the MAC address (which I got from the network configuration page)
- set a static IP address, subnet mask and default gateway on the machine, power cycled, and tried to ping the address from the PC
- have performed a network reset on the MFC, then set the network configuration on this machine to resemble the exact network configuration on the MFC that we have in our office

Also note that there are no link lights on the MFC's NIC when connected via cable.

Have I exhausted my troubleshooting options? Should I get the NIC replaced, as Brother suggested?

Regards,
Eric.

(resubmitted as I only assigned 50 points, instead of abusing the maximum 500 points I get to offer)
stvmphAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

hdhondtCommented:
What are the addresses of the MAC and the PCs? If they are not on the same subnet, does the Brother have the correct gateway? Can you ping the Brother if you let it get a DHCP address? If you can, what are the address, netmask and gateway settings under DHCP?

If all seems correct, and you can't ping it under DHCP, then it may well be a faulty NIC.
reverberICT TechnicianCommented:
I dont know about this specific model, but i do know that you can on some brother printers disable / turn off the nic, it might be worth grabbing the manual off the net and having a look, becuase no net lights normally means no connection which preceedes getting an ip address etc just something worth checking as i had this with a brother printer and it bugged me like crazy.
reverberICT TechnicianCommented:
aditionally in my case the printer still let me set all the network options but the nic was turned off. I have allso had this with a canon printer.
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

SnibborgOwnerCommented:
Have you downloaded and installed the Brother MFC configuration utility from their site?  Once you have installed that, you can then search for the printer.  This also acts as your utility for the scanner.  You should have had a copy supplied with the printer too.

Being the owner of one of these devices, I have found that this is a requirement to make them work on Windows workstations.

Snibborg
stvmphAuthor Commented:
I went back to the MFC and astoundingly there was a link light, which I did not notice during the other times I had checked. I performed the routine checks again of setting various boot methods, just to be sure. There was still no sign of an IP address, except one time when I set the boot method to Auto and APIPA kicked in to give it a "random" IP address.

I installed the BRAdmin Light Utility from the Brother Downloads page of this model and that did not find the MFC. I think that relies on the IP address already being set up on the same subnet in order to find it.
(http://welcome.solutions.brother.com/bsc/public/eu/eu_ot/en/dlf/download_index.html?reg=eu&c=eu_ot&lang=en&prod=mfc8370dn_eu_as&dlid=&flang=English&os=7&type2=-1#2)

I have access to two other MFCs of the same model and there was no need to turn the NIC on when I configured those two at the time. The Network User's Manual from the Solutions Center turned out to be of a different model so that didn't help, just in case there is a way.
(http://welcome.solutions.brother.com/bsc/public/eu/eu_ot/en/doc/manual_index.html?reg=eu&c=eu_ot&lang=en&prod=mfc8370dn_eu_as&dlid=&flang=English&type2=-1)

One thing I did notice about the other MFCs is that a 100BaseTX connection is going, whereas this one only has a 10BaseT connection. Doubt this could make a difference. I got this information from the Network Configuration report.

I think I have tried all of your suggestions. Does anyone have any more suggestions before I consider this a faulty NIC?
SnibborgOwnerCommented:
Sounds to me like you are getting a communications problem between the MFC and the switch.  My suspicion is that the switch is trying to communicate at 100 and the printer at 10.  Try setting the switch port and printer to 100 full duplex.

Snibborg

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
stvmphAuthor Commented:
After realising the printer was getting a 10Mbps connection, I used my laptop to determine if it also was getting a 10Mbps connection from that data point. It turned out that, it also was getting a 10Mbps. But I also found that it was on a different domain, as another division had their own switch in our cabinet. So that allowed me to change what switch that point was connected to. Still, I was getting a 10Mbps connection, but that didn't matter as the PC at that desk was also getting a 10Mbps connection. Then tested with my laptop, and the IP was working for the correct subnet.

I created a reservation for that MAC address on that subnet for the MFC. And still found that it would not work.

I decided to wheel out our department's MFC-8370DN to that department. We already know that this MFC is capable of getting onto the network, as it already has a networked printing queue. So I wanted to test whether it could have been some kind of a block on the switch, or if the NIC was indeed faulty.

Plugged the our department's MFC into the point and surely enough via DHCP, an IP address was given. Therefore, I have come to the conclusion that the NIC is indeed faulty, given that the same model of MFC is able to obtain a DHCP IP address from the same data point.

Now as far as points are concerned, I asked for troubleshooting options, not the proper solution as I basically knew right from the start that the NIC was faulty. Therefore, I believe that all of you will get points.
stvmphAuthor Commented:
Thank you for the responses. It allowed me to use more troubleshooting options to ensure that I had indeed a faulty NIC. I don't usually RTFM either so that made me at least attempt to do that.
SnibborgOwnerCommented:
Good work.  I'm glad we were able to help.

Snibborg
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.