Error while Installing Gsoap

Dear Experts,
I am installing Gsoap for developing a Web Service.
I am using Centos 5.5.
I installed openssl flex byacc
But I got Error while run : make

mv -f .deps/soapcpp2-soapcpp2.Tpo .deps/soapcpp2-soapcpp2.Po
gcc -DWITH_YACC -DWITH_FLEX  -DSOAPCPP_IMPORT_PATH="\"/usr/local/share/gsoap/import\"" -DLINUX -g -O2   -o soapcpp2 soapcpp2-soapcpp2_yacc.o soapcpp2-soapcpp2_lex.o soapcpp2-symbol2.o soapcpp2-error2.o soapcpp2-init2.o soapcpp2-soapcpp2.o -ly -lfl
/usr/bin/ld: cannot find -ly
collect2: ld returned 1 exit status
make[4]: *** [soapcpp2] Error 1
make[4]: Leaving directory `/root/gsoap-2.8/gsoap/src'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/root/gsoap-2.8/gsoap'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/root/gsoap-2.8/gsoap'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/gsoap-2.8'
make: *** [all] Error 2

Open in new window


Anyone Please help me install gSoap. Thank you very much
RichardLee1980Asked:
Who is Participating?
 
gaurav_voipConnect With a Mentor Commented:
-ly library is used by programs using Bison-generated parsers.
You can download rpm for bison develop package and you will get this library.

http://pkgs.org/centos-5-rhel-5/centos-rhel-i386/bison-devel-2.3-2.1.i386.rpm.html
0
 
fridomCEO/ProgrammerCommented:
Well search your vendor pages for a file named liby. Because that is missed by the linker as
you can see with the -ly
Regards
Friedrich
0
 
fridomCEO/ProgrammerCommented:
Small addition it seems this liby has to do with yacc.
Regards
Friedrich
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.