How to configure user permission for FTP / vsftpd on Linux

Im trying to setup an FTP-serve on Ubuntu 11. I can log in a local user, and read and copy files to the computer I am accessing from. But I can't do any write operations on the server.
The error is 553 could not create file.

I've been reading alot on this matter in different forums, and this seems to be a common problem. But so far I haven't found any solutions. I have done most of the things that are often mentioned:

I have the following settings in the vsftpd.conf:

Local users are allowed to login
Write is enabled
Local umask = 022

I am not running SELinux. At least I don't think so. This is a fresh installation from a VPS provider. And I couldnt the package in the list of installed applications.

Doesn't seem to have a firewall installed? I read that UFW is supposed to be on Ubuntu by default, but the UFW command is "not found", when trying to use it.

The permission on the folders/files seem to be 755. Shouldnt that be enough? (I am new to the Linux, so if I am missing out on something basic about permission, please enlighten me...)
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

What is the folder ownership where you are trying to write?

As what ID are you trying to ftp?
What is the write folder permission for that user

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
andre_stAuthor Commented:
Turned it was my lack of understanding of file permission in Linux. After a bit of reading, I realized that the folders and content I was trying to modify, was created by "root", and i was trying to change it with another account - which is not allowed.

After changing ownership of files/folders, and setting up usergroups - everything is working nicely :-)
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.