Cannot see Free/busy information for all clients

We cannot see the free/busy information for all users except if they have deligated or shared their calendar with another user and for only the users they share it with.

This problem has been ongoing since the migration from Exchange 2003 to 2007 about six months ago
TheSonicGodAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sirakovCommented:
Free busy is dependant on availability service in exchange 2007+
Probably your autodiscover fails
Run test-outlookwebservices affected.user@domain.com |fl
and post the results

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TheSonicGodAuthor Commented:
Hi Sirakov

ran the command and got the following errors back:

Id      : 1003
Type    : Information
Message : About to test AutoDiscover with the e-mail address userx@MyDomain.com.

Id      : 1013
Type    : Error
Message : When contacting https://MisspelledServerName.internal.MyDomain.com/autodisc
          over/autodiscover.xml received the error The remote name could not be
           resolved: 'MisspelledServerName.internal.MyDomain.com'

Id      : 1006
Type    : Error
Message : The Autodiscover service could not be contacted.

thus the error looks to be caused by the MisSpelled server name - checked DNS and it looks write - also checked in Server Configuration --> Client Access --> Outlook Web Access --> OWA --> Properties and the internal address looks to be correct - external address is blank

please let me know where I should change this - thanks
TheSonicGodAuthor Commented:
If anyone knows how to fix this auto-discovery server name issues please feel free to post. I have looked through DNS and MS exchange 2007 manager and can not find where the server names is misspelled the the about utility is pulling it from.

thanks,

TheSonicGod
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

sirakovCommented:
In exchange management shell run  :
Set-ClientAccessServer  -AutoDiscoverServiceInternalUri "https://CorrectName.Domain.com/autodiscover/autodiscover.xml"
TheSonicGodAuthor Commented:
Hi sirakov,

I tried the command and it failed as it was requesting an identity - checked online and it wanted the CAS-server - so added the option -Identity CAS-servername and it completed.

I then reran the test command: test-outlookwebservices user@domain.com |fl
and here are the results (server name is now showing correctly):

Id      : 1003
Type    : Information
Message : About to test AutoDiscover with the e-mail address user@domain.com.

Id      : 1006
Type    : Information
Message : The Autodiscover service was contacted at https://server.internal.domain.com/autodiscover/autodiscover.xml.

Id      : 1016
Type    : Success
Message : [EXCH]-Successfully contacted the AS service at https://server.internal.domain.com/ews/exchange.asmx. The elapsed time was 18 milliseconds.

Id      : 1015
Type    : Information
Message : [EXCH]-The OAB is not configured for this user.

Id      : 1014
Type    : Success
Message : [EXCH]-Successfully contacted the UM service at https://server.internal.domain.com/unifiedmessaging/service.asmx. The elapsed time was 48 milliseconds.

Id      : 1006
Type    : Success
Message : The Autodiscover service was tested successfully.

Please let me know if I need to fix the OAB error it is referring too.

thanks
sirakovCommented:
Actually it is not an error. Its just saying that OAB is not configured for web distribution.
This not an issue but if you want to enable it for web distribution go to :
Exchange MAnagment Console > Organization configuration > Offline Addres Book >right click the Default Offline Addres Book > properties > in last tab select web distribution and assign you server
TheSonicGodAuthor Commented:
Ok - will make that change and test this for the users and advise

Thanks
TheSonicGodAuthor Commented:
thanks sirakov - everything seems to be working after a server reboot.
sirakovCommented:
Glad it helped !
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.