Out of Office alert not working in Outlook 2007

We have tried a number of solutions that we have found on the internet.  All have not resolved The Out of Office attendant not working when trying to set it up in Outlook 2007, however it does work in OWA.

The latest is the we test a computer that was not on the domain, added it to the domain and installed Office 2010.  Logged in as one of the users and open Outlook 2010.  We get all the same results.
TheSonicGodAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dobbshelpCommented:
Are you using cached mode on Outlook? I've seen this cause issues with Outlook and OWA settings. Additionally I assume since it sounds like you've re-installed Outlook, but make sure your online and not working in offline mode within Outlook.

Are all of the updates and service packs installed? Is anyone else on this Exchange server having issues or it is only one user?
0
TheSonicGodAuthor Commented:
We are using cache mode for the OST files, outlook is online, all updates have been applied and it is affecting all users
0
dobbshelpCommented:
Try turning off cache mode so that Outlook is basically working in real time mode. See if setting an OOF message at that point has any bearings on the issue.
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

dobbshelpCommented:
I also tracked down the below registry change which was described as Users Cannot Enable Out Of Office Assistant When Using Outlook 2007.

Set a value for the WinhttpAuth registry entry. To do this, follow these steps:
+ Start Registry Editor. In Windows, click Start, type regedit in the Start Search box, and then press ENTER. If you are prompted for an administrator password or for confirmation, type the password, or provide confirmation.

+ Locate and then click the following registry subkey: HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\Security

+ On the Edit menu, point to New, and then click DWORD Value.
+ Type WinhttpAuth, and then press ENTER.
+ Right-click WinhttpAuth, and then click Modify.
+ In the Value data box, type 1, and then click OK.
+ Exit Registry Editor.
0
TheSonicGodAuthor Commented:
Hi Everyone,

OK - turned off cache mode and restarted outlook and then system - still got same error trying to access out of office from outlook

also, added the reg entry as listed above and restarted system and same error message.

the exact message is "Your Out of Office settings cannot be displayed, because the server is currently unavailable. Try again later"

I am wondering if the out off office settings are still pointing to the old server where as when you are logged into OWA you are already on the new server so it does not look for the old server?
0
dobbshelpCommented:
You can check which server Outlook is pointed at by opening Account Settings under the File menu for the Exchange account your working with. Then click Change on the account. It should list the server your working with from there.
0
TheSonicGodAuthor Commented:
Checked on the account settings and it does show the exchange 2007 server. I thought maybe there was a separate pointer record or setting that may be looking to the old server

Also I installed MS hotfix as per KB968858 and restarted system - same error
0
dobbshelpCommented:
You can check your DNS settings by using http://www.mxtoolbox.com/

Are you connecting to the Exchange server through any firewalls, MS ISA, Proxy server, etc? Are there any other features within Outlook that are not working as expected?

Have you looked at the Event Logs (eventvwr.msc) for any additional error messages or issues relating to this?
0
TheSonicGodAuthor Commented:
Hi dobbshelp

the server and users are all internal and windows firewall is disabled by domain default policy for all client systems. Therefore I am not sure mxtoolbox finding/settings are in play here - but let me know if you want these testing

I checked a couple of the systems error logs and found no errors at all under system, application, and security logs (windows logs) I also checked the MS office and security logs and nothing here either.

I did however find the following on the servers windows logs:

1) ERROR 12014 - Microsoft Exchange could not find a certificate that contains the domain name mail.cipherpharma.com in the personal store on the local computer. Therefore, it is unable to support the STARTTLS SMTP verb for the connector Internet with a FQDN parameter of mail.cipherpharma.com. If the connector's FQDN is not specified, the computer's FQDN is used. Verify the connector configuration and the installed certificates to make sure that there is a certificate with a domain name for that FQDN. If this certificate exists, run Enable-ExchangeCertificate -Services SMTP to make sure that the Microsoft Exchange Transport service has access to the certificate key.

and

2) ERROR - 8207 Error updating public folder with free/busy information on virtual machine CIPHEREXCH2. The error number is 0x8004010f.

I do have certificates installed for the domain and owa configurations in IIS 7 bindings on the server and IE does not report any errors when opening them up but this message seems to indicate it is missing from the client.
0
dobbshelpCommented:
Some of things I had researched on this had me leading my FW/proxy/ISA server question to the TTLS being changed or in this case sounds like it's not installed correctly or working correctly.

Below is an MS KB that explains how to troubleshoot Event ID 12014 and re-install the certs. Looks pretty simple and done through a couple of command lines.

You are correct that is all of your users are internal that mxtoolbox will not help. It only checks your public DNS records. Give the MS KB a try and let's see where that takes you.

http://technet.microsoft.com/en-us/library/bb510128(EXCHG.80).aspx
0
TheSonicGodAuthor Commented:
2 questions:

1) Can I run this with users on the exchange

2) We currently have a TLS link to another exchange server for a specific email domain (the link is setup to force TLS encryption of email only between the 2 servers for the email domains specified that they host. Will these utilities / configuration changes affect that setup?

thanks dobbshelp
0
dobbshelpCommented:
I've done this a few months back on Exchange 2010 while it had users logged in without any issues. I can't say anything for your second question just due to lack of not experiencing it. I would think however if you change the certs and you have another mail server using a cert, that cert would need to be updated on the second exchange server as well.
0
TheSonicGodAuthor Commented:
hi dobbshelp

I need some help - here are the results of the commands and I have read the technet article a number of time and I am not sure what to do next - from the results of the 2nd and 3rd command I can see they are different and the article I believe advises that they need to be the same but I am confused if there is anything wrong with the results of the 1st command and how to fix the issues.

here are the results (edited to hid private info):

1) Get-ExchangeCertificate | FL *

 
AccessRules          : {System.Security.AccessControl.CryptoKeyAccessRule, System.Security.AccessControl.CryptoKeyAccessRule}
CertificateDomains   : {exchange.mydomainpharma.com, www.exchange.mydomainpharma.com, mail.mydomainpharma.com}
CertificateRequest   :
IisServices          : {IIS://serverExch2/W3SVC/1}
IsSelfSigned         : False
KeyIdentifier        : B4A0F0F900A17CB13F4BA94E8B8E75097F300E8E
RootCAType           : ThirdParty
Services             : IMAP, POP, IIS
Status               : Valid
PrivateKeyExportable : True
Archived             : False
Extensions           : {System.Security.Cryptography.Oid, System.Security.Cryptography.Oid, System.Security.Cryptography.Oid, System.Security.Cryptography.Oid, System.Security.Cryptography.Oid, System.Security.Cryptography.Oid, System.Security.Cryptography.Oid, System.Security.Cryptography.Oid, System.ecurity.Cryptography.Oid}
FriendlyName         : mail.mydomainpharma.com
IssuerName           : System.Security.Cryptography.X509Certificates.X500DistinguishedName
NotAfter             : 4/21/2012 2:25:17 AM
NotBefore            : 11/1/2011 4:00:07 PM
HasPrivateKey        : True
PrivateKey           : System.Security.Cryptography.RSACryptoServiceProvider
PublicKey            : System.Security.Cryptography.X509Certificates.PublicKey
RawData              : {48, 130, 5, 166, 48, 130, 4, 142, 160, 3, 2, 1, 2, 2, 7, 78...}
SerialNumber         : 4EFEB316F448B7
SubjectName          : System.Security.Cryptography.X509Certificates.X500DistinguishedName
SignatureAlgorithm   : System.Security.Cryptography.Oid
Thumbprint           : 483F9CBD12701C333355B536EC5406C13227D7C1
Version              : 3
Handle               : 466522112
Issuer               : SERIALNUMBER=07969287, CN=Go Daddy Secure Certification Authority, OU=http://certificates.godaddy.com/repository, O="GoDaddy.com, Inc.", L=Scottsdale, S=Arizona, C=US
Subject              : CN=exchange.mydomainpharma.com, OU=Domain Control Validated, O=exchange.mydomainpharma.com
AccessRules          : {System.Security.AccessControl.CryptoKeyAccessRule, System.Security.AccessControl.CryptoKeyAccessRule}
CertificateDomains   : {exchange.mydomainpharma.com, www.exchange.mydomainpharma.com}
CertificateRequest   :
IisServices          : {}
IsSelfSigned         : False
KeyIdentifier        : 6327EE36992FF481FD131F7D2ED671D66A9854F1
RootCAType           : Unknown
Services             : IMAP, POP
Status               : Invalid
PrivateKeyExportable : True
Archived             : False
Extensions           : {System.Security.Cryptography.Oid, System.Security.Cryptography.Oid, System.Security.Cryptography.Oid, System.Security.Cryptography.Oid, System.Security.Cryptography.Oid, System.Security.Cryptography.Oid, System.Security.Cryptography.Oid, System.Security.Cryptography.Oid, System.Security.Cryptography.Oid}
FriendlyName         : Microsoft Exchange
IssuerName           : System.Security.Cryptography.X509Certificates.X500DistinguishedName
NotAfter             : 4/21/2012 2:25:17 AM
NotBefore            : 9/15/2011 1:50:05 AM
HasPrivateKey        : True
PrivateKey           : System.Security.Cryptography.RSACryptoServiceProvider
PublicKey            : System.Security.Cryptography.X509Certificates.PublicKey
RawData              : {48, 130, 5, 143, 48, 130, 4, 119, 160, 3, 2, 1, 2, 2, 7, 4...}
SerialNumber         : 04532A19B3CA12
SubjectName          : System.Security.Cryptography.X509Certificates.X500DistinguishedName
SignatureAlgorithm   : System.Security.Cryptography.Oid
Thumbprint           : DD205E83E1476D196761DE1A597B65276BB4CE2C
Version              : 3
Handle               : 466518912
Issuer               : SERIALNUMBER=07969287, CN=Go Daddy Secure Certification Authority, OU=http://certificates.godaddy.com/repository, O="GoDaddy.com, Inc.", L=Scottsdale, S=Arizona, C=US
Subject              : CN=exchange.mydomainpharma.com, OU=Domain Control Validated, O=exchange.mydomainpharma.com
AccessRules          : {System.Security.AccessControl.CryptoKeyAccessRule, System.Security.AccessControl.CryptoKeyAccessRule}
CertificateDomains   : {serverExch2, serverExch2.internal.mydomainpharma.com}
CertificateRequest   : MIID3DCCAsQCAQAwFjEUMBIGA1UEAwwLQ2lwaGVyRXhjaDIwggEiMA0GCSqGSIb3DQEBAQUAA4IBDwAwggEKAoIBAQCQgmIhhS676H79kk0URyfG2LuVNxBzHalrrEVDNa6D+QTWbpmJy3GskTR8GgbBoaEPzOS64XzGwDIqI/TgKtZrkCjwzsE2oC9XOae437Xdt3uZpw49ipOktYZYzY5ZUlVYJXOMPt+gkUAFMjHjRUjJhoDX6pcbj7Wd7AFUE8gKn8cgIKOSYaVIY1KHmTttGsMrUIBB5gJvrh7w47QpBa0vxwKRAtOHOobgnvPiqy7TyvqWOO4nfRHZU3iWycM1qidFU2cM8PARrlXLc0XVd6xVMABFBj5XfEtiT6F05smKXoLDiRXbJ7UB4p9SKbaUA2v5btaeFrzbfXLKaXex8DAgMBAAGgggFMBoGisGAQQBgjcNAgMxDBYKNi4wLjYwMDIuMjBfBgkrBgEEAYI3FRQxUjBQAgEFDCVDaXBoZXJFeGNoMi5pbnRlcm5hbC5jaXBoZXJwaGFybWEuY29tDBRDSVBIRVJcYWRtW5pc3RyYXRvcgwOcG93ZXJzaGVsbC5leGUwcgYKKwYBBAGCNw0CAjFkMGICAQEeAYwByAG8AcwBvAGYAdAAgAFIAUwBBACAAUwBDAGgAYQBuAG4AZQBsACAAAB0AG8AZwByAGEAcABoAGkAYwAgAFAAcgBvAHYAaQBkAGUAgMBADCBJ%åi¿¤»o¿
IisServices          : {}
IsSelfSigned         : True
KeyIdentifier        : B4850753F6C8A7545EEE5047BC8FA95A1BC5026E
RootCAType           : None
Services             : None
Status               : Valid
PrivateKeyExportable : False
Archived             : False
Extensions           : {System.Security.Cryptography.Oid, System.Security.Cryptography.Oid, System.Security.Cryptography.Oid, System.Security.Cryptography.Oid, System.Security.Cryptography.Oid}
FriendlyName         : Microsoft Exchange
IssuerName           : System.Security.Cryptography.X509Certificates.X500DistinguishedName
NotAfter             : 9/12/2012 9:59:42 PM
NotBefore            : 9/12/2011 9:39:42 PM
HasPrivateKey        : True
PrivateKey           : System.Security.Cryptography.RSACryptoServiceProvider
PublicKey            : System.Security.Cryptography.X509Certificates.PublicKey
RawData              : {48, 130, 3, 108, 48, 130, 2, 84, 160, 3, 2, 1, 2, 2, 16, 50...}
SerialNumber         : 324753D5C43A7DB24723989406D01208
SubjectName          : System.Security.Cryptography.X509Certificates.X500DistinguishedName
SignatureAlgorithm   : System.Security.Cryptography.Oid
Thumbprint           : EFD5E8045BC8D0BE04F0DB25A09C77A9051AF50A
Version              : 3
Handle               : 466518528
Issuer               : CN=serverExch2
Subject              : CN=serverExch2
AccessRules          : {System.Security.AccessControl.CryptoKeyAccessRule, System.Security.AccessControl.CryptoKeyAccessRule, System.Security.AccessControl.CryptoKeyAccessRule, System.Security.AccessControl.CryptoKeyAccessRule}
CertificateDomains   : {serverExch2, serverExch2.internal.mydomainpharma.com}
CertificateRequest   :
IisServices          : {}
IsSelfSigned         : True
KeyIdentifier        : 5A2B24F3E074E24E7F3F7B16E02541B5FC3DB641
RootCAType           : None
Services             : SMTP
Status               : Valid
PrivateKeyExportable : False
Archived             : False
Extensions           : {System.Security.Cryptography.Oid, System.Security.Cryptography.Oid, System.Security.Cryptography.Oid, System.Security.Cryptography.Oid}
FriendlyName         : Microsoft Exchange
IssuerName           : System.Security.Cryptography.X509Certificates.X500DistinguishedName
NotAfter             : 7/5/2012 10:18:50 PM
NotBefore            : 7/5/2011 10:18:50 PM
HasPrivateKey        : True
PrivateKey           : System.Security.Cryptography.RSACryptoServiceProvider
PublicKey            : System.Security.Cryptography.X509Certificates.PublicKey
RawData              : {48, 130, 3, 42, 48, 130, 2, 18, 160, 3, 2, 1, 2, 2, 16, 109...}
SerialNumber         : 6D107F3E854BCFBD41386EA9919BB0FC
SubjectName          : System.Security.Cryptography.X509Certificates.X500DistinguishedName
SignatureAlgorithm   : System.Security.Cryptography.Oid
Thumbprint           : 6D15FE2944D2030F179CFAD5C9A0A4ED1CE9E38B
Version              : 3
Handle               : 466519808
Issuer               : CN=serverExch2
Subject              : CN=serverExch2

Open in new window


2) Get-ReceiveConnector | FL name, fqdn, objectClass

Name        : Default serverEXCH2
Fqdn        : serverExch2.internal.mydomainpharma.com
ObjectClass : {top, msExchSmtpReceiveConnector}

Name        : Client serverEXCH2
Fqdn        : serverExch2.internal.mydomainpharma.com
ObjectClass : {top, msExchSmtpReceiveConnector}

3) Get-SendConnector | FL name, fqdn, objectClass

Name        : Internet
Fqdn        : mail.mydomainpharma.com
ObjectClass : {top, msExchConnector, mailGateway, msExchRoutingSMTPConnector}

Name        : FDA
Fqdn        : mail.mydomainpharma.com
ObjectClass : {top, msExchConnector, mailGateway, msExchRoutingSMTPConnector}

Name        : Default
Fqdn        :
ObjectClass : {top, msExchConnector, mailGateway, msExchRoutingSMTPConnector}



thanks for your help
0
TheSonicGodAuthor Commented:
HI dobbshelp

discovered that the OAB and GAL are still located on the old exchserver - I will move these and rerun the above items then update this post

thanks,

TheSonicGod
0
TheSonicGodAuthor Commented:
This is now working correctly - resolved the issue by moving the OAB and GAL to the new server and resolved the auto-discovery settings for the new exchange server
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TheSonicGodAuthor Commented:
Issue was found partitally from the KB article listed about and other research

gave B rating as we were about to check other items that as we now know were not related to the issue
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.