point to point link between two 2911 routers

Hi , i have a Layer 2 point to point link.

On router 1 i have

tpumapuertor1#sh run int fa0/2/0
Building configuration...

Current configuration : 143 bytes
!
interface FastEthernet0/2/0
 description --- Puma  cARIBE  to Puma  Puerto Rico  ---
 switchport access vlan 96
 duplex full
 speed 100
end

on router 2 i have

tpumacariber01#sh run int fa0/2/3
Building configuration...

Current configuration : 146 bytes
!
interface FastEthernet0/2/3
 description --- Puma  cARIBE  to Puma  Puerto Rico  ---
 switchport access vlan 96
 duplex full
 speed 100
 !
end


put when i ping from one side to another it goes through another vlan , vlan 97



tpumapuertor1#sh ip route 10.200.158.249
Routing entry for 10.200.158.248/30
  Known via "eigrp 100", distance 90, metric 298538767, type internal
  Redistributing via eigrp 100
  Last update from 10.200.158.154 on Vlan97, 1d00h ago
  Routing Descriptor Blocks:
  * 10.200.158.154, from 10.200.158.154, 1d00h ago, via Vlan97
      Route metric is 298538767, traffic share count is 1
      Total delay is 550560 microseconds, minimum bandwidth is 9 Kbit
      Reliability 255/255, minimum MTU 1468 bytes
      Loading 226/255, Hops 5

tpumapuertor1#
protocol is eigrp .
any ideas ?
c_hocklandAsked:
Who is Participating?
 
Don JohnstonConnect With a Mentor InstructorCommented:
Possibly. Clear the counters and check it again after 15 minutes.
0
 
Don JohnstonInstructorCommented:
You're going to have to provide a lot more information.

What are these two devices? (model number, please)
How many paths exist between these two devices?
What are the IP addresses on these two devices?

Seeing the configs of the two devices would help.
0
 
c_hocklandAuthor Commented:
they are 3750 cisco switches
there is only a P2P path between these two switches
 I will see if i can copy paste the configs
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Don JohnstonInstructorCommented:
If there is only one path between the switches, then that's the only path that can be used.

I'm guessing that the link is a trunk. Why it's taking one VLAN and not another can only be determined by viewing the configs of both switches.
0
 
adrianuta2004Commented:
if you have only one link between those 2 switches ( i mean you have no redundant path between them ) there is no way your traffic between them flow on vlan 97, as long as you have ports on access mode for vlan 96. :)
0
 
c_hocklandAuthor Commented:
i do have ports on vlan 96. I will copy paste the config asap
0
 
c_hocklandAuthor Commented:
vlan 96,99
!
ip ssh version 2
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 description --- Internal Interface ---
 ip address 172.19.35.3 255.255.255.0
 ip virtual-reassembly
 duplex full
 speed 100
 standby 1 ip 172.19.35.2
 standby 1 timers 2 4
 standby 1 priority 254
 standby 1 preempt
 
 !
!
interface FastEthernet0/1
 description -- External Interface --
 ip address 204.15.147.134 255.255.255.252
 ip access-group extended in
 ip inspect Firewall out
 duplex full
 speed 100
 !
!
interface FastEthernet0/2/0
 !
!
interface FastEthernet0/2/1
 !
!
interface FastEthernet0/2/2
 !
!
interface FastEthernet0/2/3
 description --- Puma  cARIBE  to Puma  Puerto Rico  ---
 switchport access vlan 96
 duplex full
 speed 100
 !
!
interface Vlan1
 no ip address
 !
!
interface Vlan96
 ip address 10.200.158.249 255.255.255.252
 !
!
!router eigrp 100
 network 10.200.157.0 0.0.0.255
 network 10.200.158.0 0.0.0.255
 network 172.19.35.0 0.0.0.255
 network 172.19.37.0 0.0.0.255
 passive-interface FastEthernet0/1
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip tacacs source-interface FastEthernet0/0
!
ip access-list standard SNMP
 permit 172.18.193.30
 permit 172.20.9.50
 permit 172.24.1.30
 permit 172.21.1.95
 permit 172.20.1.87
 permit 172.20.1.86
 deny   any log
 permit 172.20.1.87

0
 
c_hocklandAuthor Commented:
tpumacariber01#ping 10.200.158.249

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.200.158.249, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
tpumacariber01#sh ip route 10.200.158.249
Routing entry for 10.200.158.249/32
  Known via "connected", distance 0, metric 0 (connected)
  Redistributing via eigrp 100
  Routing Descriptor Blocks:
  * directly connected, via Vlan96
      Route metric is 0, traffic share count is 1
tpumacariber01#
tpumacariber01#sh ip route 10.200.158.250
Routing entry for 10.200.158.248/30
  Known via "connected", distance 0, metric 0 (connected, via interface)
  Redistributing via eigrp 100
  Routing Descriptor Blocks:
  * directly connected, via Vlan96
      Route metric is 0, traffic share count is 1
tpumacariber01#ping 10.200.158.250

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.200.158.250, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
tpumacariber01#
0
 
Don JohnstonInstructorCommented:
Is the problem that the traffic takes the wrong path or that it doesn't work at all?
0
 
c_hocklandAuthor Commented:
i am not sure...when i do sh route....it shows that he knows that the path is the "directly connected" interface.
When i traceroute
tpumacariber01#traceroute 10.200.158.250

Type escape sequence to abort.
Tracing the route to 10.200.158.250

  1  *  *  *
  2  *  *  *
  3  *  *  *
  4  *  *  *
  5  *  *  *


seems the other side doesnt respond. I will copy paste the show route...from the other router....
0
 
Don JohnstonInstructorCommented:
Post the output of a "show IP route"

What is the device with IP address 10.200.158.250? If it's the other switch,  please post the config of that device.
0
 
c_hocklandAuthor Commented:
interface FastEthernet0/0
 description --- Internal ---
 ip address 172.18.65.4 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip route-cache flow
 duplex full
 speed 100
 standby 1 ip 172.18.65.2
 standby 1 timers 2 4
 standby 1 priority 254
 standby 1 preempt
 standby 1 authentication 3toAthi@
 service-policy input markDSCP
!        
interface FastEthernet0/1
 description --- AT&T External ---
 ip address 12.156.185.194 255.255.255.240
 ip access-group External in
 ip nat outside
 ip inspect Firewall out
 ip virtual-reassembly
 ip route-cache flow
 duplex full
 speed 100
 crypto map VPN.Tunnels
!        
interface FastEthernet0/2/0
 description --- Puma  cARIBE  to Puma  Puerto Rico  ---
 switchport access vlan 96
 duplex full
 speed 100
!        
interface FastEthernet0/2/1
 description --- link to CIM vlan 97 ---
 switchport access vlan 97
 duplex full
 speed 100
!        

interface FastEthernet0/2/2
!        
interface FastEthernet0/2/3
!        
interface Vlan1
 no ip address
!        
interface Vlan96
 description --- Connection to Puma Caribe ---
 ip address 10.200.158.250 255.255.255.252
!        
interface Vlan97
 description --- Link to CIM vlan 97 ---
 ip address 10.200.158.153 255.255.255.252
!        
router eigrp 100
 passive-interface FastEthernet0/1
 network 10.200.153.0 0.0.0.255
 network 10.200.155.0 0.0.0.255
 network 10.200.156.0 0.0.0.255
 network 10.200.157.0 0.0.0.255
 network 10.200.158.0 0.0.0.255
 network 172.18.64.0 0.0.15.255
 no auto-summary
!        
ip route 0.0.0.0 0.0.0.0 12.156.185.193 name ---->DG
!        

0
 
c_hocklandAuthor Commented:
tpumacariber01#
tpumacariber01#sh ip route | i 10.200.158.250
tpumacariber01#sh ip route | i 10.200.158.249
L        10.200.158.249/32 is directly connected, Vlan96
tpumacariber01#



on the other router

tpumapuertor1#
tpumapuertor1#
tpumapuertor1#
tpumapuertor1#
tpumapuertor1#sh ip route | i 10.200.153.249
tpumapuertor1#sh ip route | i 10.200.153.250
tpumapuertor1#
0
 
Don JohnstonInstructorCommented:
The problem is on the .250 switch. Looks like the 0/2/0 interface is down. Post the output of a "show int status " on that switch.
0
 
c_hocklandAuthor Commented:
interface FastEthernet0/2/0
 description --- Puma  cARIBE  to Puma  Puerto Rico  ---
 switchport access vlan 96
 duplex full
 speed 100
end

tpumapuertor1#sh int status

Port    Name               Status       Vlan       Duplex Speed Type
Fa0/2/0 --- Puma  cARIBE   connected    96           full     100 10/100BaseTX
Fa0/2/1 --- link to CIM vl connected    97           full     100 10/100BaseTX
Fa0/2/2                    notconnect   1            auto    auto 10/100BaseTX
Fa0/2/3                    notconnect   1            auto    auto 10/100BaseTX
tpumapuertor1#
0
 
c_hocklandAuthor Commented:
ah look at vl96

tpumapuertor1#sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            172.18.65.4     YES NVRAM  up                    up      
FastEthernet0/1            12.156.185.194  YES NVRAM  up                    up      
FastEthernet0/2/0          unassigned      YES unset  up                    up      
FastEthernet0/2/1          unassigned      YES unset  up                    up      
FastEthernet0/2/2          unassigned      YES unset  down                  down    
FastEthernet0/2/3          unassigned      YES unset  down                  down    
Vlan1                      unassigned      YES TFTP   up                    down    
Vlan96                     10.200.158.250  YES manual up                    down    
Vlan97                     10.200.158.153  YES manual up                    up      
NVI0                       unassigned      NO  unset  up                    up      
Tunnel318                  10.200.153.114  YES NVRAM  up                    up      
0
 
c_hocklandAuthor Commented:
ok , its fixed now.
0
 
c_hocklandAuthor Commented:
tpumapuertor1#sh ip int br
Dec 16 18:26:19: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan96, changed state to up
tpumapuertor1#sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            172.18.65.4     YES NVRAM  up                    up      
FastEthernet0/1            12.156.185.194  YES NVRAM  up                    up      
FastEthernet0/2/0          unassigned      YES unset  up                    up      
FastEthernet0/2/1          unassigned      YES unset  up                    up      
FastEthernet0/2/2          unassigned      YES unset  down                  down    
FastEthernet0/2/3          unassigned      YES unset  down                  down    
Vlan1                      unassigned      YES TFTP   up                    down    
Vlan96                     10.200.158.250  YES manual up                    up      
Vlan97                     10.200.158.153  YES manual up                    up      
NVI0                       unassigned      NO  unset  up                    up      
Tunnel318                  10.200.153.114  YES NVRAM  up                    up      
Tunnel319                  10.200.153.118  YES NVRAM  up                    up      
Tunnel416                  10.200.155.42   YES NVRAM  up                    up      
tpumapuertor1#
Dec 16 18:26:50: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: N
0
 
c_hocklandAuthor Commented:
I did not have the vlan96 created in the vlan database on the router..

so i did

config t
vl96
end

but my question is ...

i had the intrface vlan 76 configured with an IP

i thought that , this was enough....
0
 
c_hocklandAuthor Commented:
My only issue is that is flapping

Dec 16 18:33:42: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 10.200.158.249 (Vlan96) is up: new adjacency
Dec 16 18:35:02: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 10.200.158.249 (Vlan96) is down: Interface Goodbye received
Dec 16 18:35:02: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 10.200.158.249 (Vlan96) is up: new adjacency
Dec 16 18:36:22: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 10.200.158.249 (Vlan96) is down: Interface Goodbye received
Dec 16 18:36:26: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 10.200.158.249 (Vlan96) is up: new adjacency
tpumapuertor1#
tpumapuertor1#shrun | s eigrp
                ^
% Invalid input detected at '^' marker.

tpumapuertor1#sh run | s eigrp
router eigrp 100
 passive-interface FastEthernet0/1
  network 10.200.157.0 0.0.0.255
 network 10.200.158.0 0.0.0.255
 no auto-summary


shall i do

no passive-interface fa0/2/0 ?
0
 
c_hocklandAuthor Commented:
i am getting CRC and Input errors on the interface.

Is it a wire issue ?

Received 426398 broadcasts, 0 runts, 3 giants, 0 throttles
     21 input errors, 12 CRC, 0 frame, 3 overrun, 0 ignored
0
 
c_hocklandAuthor Commented:
thanks.  I will go ahead and give the points because you helped me tremendously!

Many thanks.
0
 
Don JohnstonInstructorCommented:
Seems like physical layer problem to me. Connector,  cable, wire, provider, etc.
0
 
c_hocklandAuthor Commented:
thanks. I already email the provider. Unfortunately they are in Puerto Rico and i am in Houston...so there might be some delay in coming back to me. But i will keep u posted.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.