Increasing throughput on iSCSI switch

i have a pair of Dell PowerConnect 5424 switches that are used specifically for iSCSI.  I have 6 ports setup between the two but i only get 1 Gbps speeds.  I would think that it would aggregate them together so that i would get 6 Gbps.

Here is a basic overview of the switch configuration.

Port 1 - VLAN 1 - Management

Port 2-18 - VLAN 11 - iSCSI

Port 19-24 - VLAN 11 - LAG between both switches.  Currently only displaying speed of 1 Gbps.  I'd like this to show 6 Gbps.

Here are the commands that i used to configure both switches.
 
console(config)# vlan database
console(config-vlan)# vlan 11
console(config-vlan)# ex
console(config)# interface vlan 11
console(config-if)# name iSCSI
console(config-if)# ip address xxx.xxx.xxx.xxx  255.255.255.0
console(config-if)# ex
console(config)# interface vlan 1
console(config-if)# ip address xxx.xxx.xxx.xxx 255.255.255.0
console(config-if)# ex

console(config)# interface range ethernet g(19-24)
console(config-if)# channel-group 1 mode auto
console(config-if)# end

console# config
console(config)# no iscsi enable
console(config)# port jumbo-frame
console(config)# interface range ethernet g(2-18)
console(config-if)# flowcontrol on
console(config-if)# spanning-tree portfast
console(config-if)# switchport access vlan 11
console(config-if)# ex

console(config)# interface port-channel 1
console(config-if)# flowcontrol on
console(config-if)# switchport mode trunk
console(config-if)# switchport trunk allowed vlan add 11
console(config-if)# end

Open in new window

LVL 2
c3veryAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

eeRootCommented:
How are you doing the speed test to see if you are getting 6 Gbps speeds?  Your testing equipment may be on 1Gbps ports, and therefore cannot move data over that speed.
0
Soulja53 6F 75 6C 6A 61 Commented:
While Link aggregation bundles the interfaces into one logical port, they are still only going to transfer data over single interface per ip, mac, etc. What I mean is a host transmitting data across your LAG is not going to use but one interface in that LAG, so 1Gps is correct.

Another analogy is look at it as a 6 lane highway. While you will be able to fit more traffic on the highway (LAG)  a car (host) can only use one lane at a time.
0
c3veryAuthor Commented:
I've gathered the data from SNMP.  Other switches that i have 2 port LAGs show a 2 Gbps speed.  I understand that other ports on the switch are single 1 Gbps ports and i'm not expecting those devices to use more than what the port allows.  My concern is when i have multiple 1 Gbps devices, is the 6 port lag smart enough to know which "lanes" are more open and free instead of having the "cars" in a single lane at a time.  Since this is iSCSI based i just want to make sure i mitigate congestion as much as possible.  Hope that makes sense.
0
Soulja53 6F 75 6C 6A 61 Commented:
I don't know about the snmp issue, but yes the LAG will load balance the traffic across the links. You should have no issue there.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
c3veryAuthor Commented:
Thanks, that's all i needed to know.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.