Linksys WRT54G & Comcast Cable Modem (Moto SB6121) Installation

Totally stumped here. I had the WRT54G working on my ATT DSL setup, but now have switched to Comast. The wired Ethernet ports are working. I can surf from my desktop fine. But I cannot get wireless access working through the WRT54G. With DSL, all my home networking devices had a private IP address in the 192.168.1.x subnet and I could connect to everything and basically understood what was going on. With the Comcast setup, the modem is much less configurable for the internal/private network. It defaults to 192.168.100.1, and I can connect to it via it's web interface and ping it from the desktop. So, I set the WRT54G to 192.168.100.2. I can connect to it if I hard wire my laptop to it and give the laptop a static IP on the 192.168.100.x subnet. But I cannot ping the WRT54G from my desktop at that address. And when I run ipconfig on the desktop, I don't get an address in the 192.168.100.x subnet, I get an address in the 69.180.114.x subnet. Any attempt at connecting my laptop wirelessly ends up with a failed attempt to get an IP address. DHCP is enabled in the cable modem, not in the router. I'm so totally lost I don't know where to begin.
LVL 1
tcianfloneAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

taphopeCommented:
If the router is still setup to work as a router, enable DHCP on the router.  Even though the modem has DHCP on it, most home routers if still set to router mode won't relay dhcp requests to a different subnet.  

Usually if I run into goofiness like that I would reset the router to factory defaults and try to connect to it wirelessly with it unsecured and see how it works.  If it works reconfigure the router SSID and WPA2 and try again.  
0
tcianfloneAuthor Commented:
I don't really need router functionality; the cable modem is doing that, I think. I only use it as a wireless access point really. How do I configure it to NOT act as a router and is that the path I should take? When using it with ATT, everything was on the same subnet, and that's probably why it worked. Now, I don't know. In any case, I'll try resetting it to default and try it unsecured and see what happens. Can't be any worse than it is now.
0
tcianfloneAuthor Commented:
Oh, and any idea why I can't ping the wireless router at 192.168.100.2?
0
How do you know if your security is working?

Protecting your business doesn’t have to mean sifting through endless alerts and notifications. With WatchGuard Total Security Suite, you can feel confident that your business is secure, meaning you can get back to the things that have been sitting on your to-do list.

Fred MarshallPrincipalCommented:
Take a look at this and then tell us what's different... please.

Is DHCP turned on on the router?
What's connected to the router WAN port?
It can be either way, the WAN port connected or not.  But that makes a real difference how you set things up.
Wireless-Router-as-a-Simple-Swit.pdf
0
Dave BaldwinFixer of ProblemsCommented:
The Comcast setups that I have worked on only give out a single IP address and do not act as a router.  Comcast used to use a Linksys wireless router that took care of it but they have switched to the Motorola device and a Netgear wireless router.  I have one customer that uses a WRT54 with his Comcast service but when it goes down, I have to connect directly to the cable modem to restart it and then plug it into the WRT54.  

Another customer subscribed to the Comcast wireless service and when the old Linksys unit stopped working, she had to get both the Motorola unit and the Netgear unit to get it running again.  Under that plan, the Motorola cable modem will not work by itself.
0
tcianfloneAuthor Commented:
In reply to fmarshall's questions: I'm not using the wireless router Internet port, just the four switch ports. DHCP is NOT enabled in the wireless router, only in the modem. The Ethernet cable from the modem is connected to one of the four wireless router ports. My desktop is connected to another of the four wireless router ports. No problem with the desktop connectivity, but I notice that all active port LEDs flash constantly as if there's constant activity. That was never the case with the DSL setup, and that's a little baffeling. Something else I just tried: I connected my laptop wired Ethernet connection to one of the wireless router ports and the laptop is not getting IP address over the wire either. ipconfig /renew times out. That tells me that the DHCP server in the modem is not servicing connections made to the wireless router ports, other than my desktop PC??? Just gets more confusing.
0
taphopeCommented:
You could also toss dd-wrt on the wrt54g.  Gives a lot more options to use but I would read up on it first.  It COULD be that your router has also gone flakey coincidentally.  
0
tcianfloneAuthor Commented:
Further testing: I enabled the DHCP server on the wireless router and now I can get DHCP addresses on the wireless adapter and the wired adapter on the laptop. Interestingly, even thought the DHCP config in the wireless router shows a DHCP starting address of 192.168.1.50, the laptop is getting DHCP addresses in the 192.168.100.x subnet! And even though I'm getting DHCP addresses now on the laptop, I STILL CANNOT access the web!!!
0
taphopeCommented:
Try it from a default configuration.  Reset the router to factory, and if needed the modem too.
0
Fred MarshallPrincipalCommented:
Well, I've seen in the dim past where a modem like that would start out handing out a public IP address as you've seen AND then switch to handing out private addresses.  It's obviously a mode change but I wasn't aware of having done anything to cause it.  So, you might watch out for that.

The easiest way to deal with this is:

Plug the modem into the WAN/Internet side of the router.  The router is capable of getting an IP address via DHCP - so set up the WAN that way.
Now, just make sure that the router LAN IP address / subnet is different from the WAN subnet.
For example:

If the router WAN address is 192.168.1.100 / 255.255.255.0
Then set up the router LAN to be NOT in 192.168.1.0 / 255.255.255.0
Set up the router LAN to be something like 192.168.2.0 /255.255.255.0
If the router WAN address is a public address then you don't need to worry about this as the LAN subnet defaults to 192.168.1.0 / 255.255.255.0 on a WRT54G.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Fred MarshallPrincipalCommented:
And, all of the computers, wired or wireless will be on the Linksys only.
0
tcianfloneAuthor Commented:
I have terminated the Comcast experiment here and have opted to stick with ATT DSL. The Moto SB6121 router is not configurable at all, I don't understand the implementation with my WRT54G router, and nothing I try gets it to work. I'm done with it.
0
tcianfloneAuthor Commented:
I never got this to work and gave up on it. Split up the points between the two most helpful responders. Thanks.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.