Outlook 2010 needs password after Exchange 2010 reboot

I recently migrated from Exchange 2003 to 2010. Every time there is a connection loss to the server for any reason, Outlook 2010 goes into "need password" mode. Even if the connection is restored.  I turned off "Outlook anywhere" in Exchange 2010 but it still happens.  Any ideas?
SedrynAsked:
Who is Participating?
 
Madan SharmaConsultantCommented:
yes this is the default behavior but I believe this is for internal users only if you have external users who are using outlook their outlook will not prompt for password instead it will only show the outlook disconnect and will connect automatically once the exchange become online.
0
 
the_endjinnCommented:
Do you have 'Always prompt for logon credentials' ticked in the Security tab of the mailbox properties in Outlook 2010?

Tools -> Account Settings -> Change -> Security tab
0
 
SedrynAuthor Commented:
Users are not prompted with their 2003 clients. Not an account issue.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
the_endjinnCommented:
The 'Always prompt for logon credentials' is a per Outlook client option, so could be set in 2010 but not in 2003. If it's not set in either however then it's a moot point :)
0
 
Madan SharmaConsultantCommented:
first you have to check for what exchange is asking for login again & again.
Just do right click on outlook icon in right side task bar just holding up Ctrl key then click on Connection Status and under General Tab check for what it in connecting state. if possible please post a screenshot of it. So that we can suggest you the appropriate solution for the issue.
0
 
SedrynAuthor Commented:
Still no go. I talked to an engineer who says it is not possible to fix this.  It will always prompt and the only way to get connected is to close and re-open Outlook.
0
 
SedrynAuthor Commented:
Found a fix..
Create a batch file on the all users desktop with the following:

NET STOP msexchangerpc
Shutdown -r -t 15

Always use this to restart the system. It shuts down the service that causes users to have to log back in. Worked in our case at least.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.