Crystal Server Scheduling function how do I block or gray out filters

We are moving our reports from Crystal XI to crystal server for security reasons.  When using the scheduling function it allows you to change or input the parameters but it also allows you to change the filters that are set up.  Is there a way to block out or disable the ability to change the filters in the scheduling function.
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Log into the Crystal Management Console. There will be check boxes on each parameter to "Prompt". If you uncheck this box, the report will use whatever parameter you have pre-selected when it is run/scheduled through InfoView.

srw1029Author Commented:
The parameters are ok but I need to lock down the filter section which it allows you to change.
aaah, i see what you mean. i am not aware of a way to lock down the report selection criteria.

you could 1) apply those filters within a view, and point the report to the view (or, if you aren't allowed to build views, make a COMMAND statement be the source).
2) Add a //comment in the report filter telling users: "do not change this box, as your report will not run correctly." I guess it depends on if they are  doing it on purpose to get around security or if they are just changing it on accident...

If it is a security issue, you may need to look into making "Business Views" where you can lock down records based on the user running the report. Business View Manager should be on your Crystal Reports Server install disk, and can be installed locally on your development machine and connected to your crystal server.
Kurt ReinhardtSr. Business Intelligence Consultant/ArchitectCommented:
Please see the attached screenshot (assuming you're upgrading to at least Crystal Reports Server 2008).  You'll need to go into the CMC, Applications, drill down into Infoview settings and uncheck the [Show "Filters" tab on the Schedule] page setting. Please note, this is an on/off settings, so it'll be off for everybody who uses Infoview, including Administrators.  That's fine, because Infoview is for end users and the CMC is for Administrators.

FYI, I turn this off for every system I deploy.  You absolutely do NOT want end users messing with record selection at runtime unless you like them locking up the server by inadvertently removing server-side processing or doing "SELECT *"

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
srw1029Author Commented:
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Crystal Reports

From novice to tech pro — start learning today.