Convert Vlan to Trunk Mode

Hello Experts,
I need to inquire about modifying a Cisco 3560 Switch port.
I have physical server running Hyper-V.  
This Hyper-V Server (Currently VLAN10) I would like to have
host several VLANS, (10,20,30,40)

I know how to enable VLANs on the Hyper-V Server Network Adapter.
However, the Switches I am not certain what is the best option to use for
this situaton.

Currently the Port Setting is as follows below.

CURRENT:
interface GigabitEthernet0/1
 description Connection to Server Port 1
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast

There are two options.  Not sure which one

OPTION 1:

interface Port-channel3
switchport trunk encapsulation dot1q
switchport trunk native vlan 10    (The native vlan of the server)
switchport mode trunk

interface GigabitEthernet 0/1
description Connection to Server Port 1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 3 mode on


OR  OPTION 2:

interface GigabitEthernet 0/1
description Connection to Server Port 1
switchport trunk encapsulation dot1q
switchport mode trunk

cnetwizAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

EyeNoVoIPCommented:
Both options are missing the native vlan configuration on the interface itself.  Please add this to them switchport trunk native vlan 10.  See below:

interface GigabitEthernet 0/1
description Connection to Server Port 1
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport mode trunk

Port-Channels are typically used to aggregate multiple links together.  If you have multiple links that you want to represent one physical link then Option 1 would be the way to go.  If not then I'd stick with Option 2 for now.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cnetwizAuthor Commented:
Thank you for your response.

A follow-up question, the physical server has two ports.  Each port goes to its own switch.
Both switches are connected to one another via trunking
If I understand your Port-Channel statement,  would need to go with the first option then?
0
rm-entCommented:
You cannot port-channel between 2 different 3560s the connections would have to be on the same switch. Port-channels are only local to the device they are created on.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.