missing httponly flag from Cookie vulnerabililty on OWA port 443

After receiving a security penetration check....they are suggesting we fix the OWA HTTPS service vulnerabilities. The only answers I can find is on google is telling me how to change in  .net or java. I don't know what owa usses besides iis. I am not a programmer. Can anyone tell me exactly how to fix these security issues. I have exchange 7 running on server 2008 sp2 using https for outlook we access
jtanoAsked:
Who is Participating?
 
jtanoAuthor Commented:
NO, sorry we never did get an answer or fix. We just ignore it now when we do the security test
0
 
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
did you enable SSL for OWA virutal Directory in IIS, you should point to OWA virtual directory on the right pane click on SSL then choose Required SSL choose ignore , then ok -> restart IIS and do test again
0
 
jtanoAuthor Commented:
Yes, I had done that, but the security test says:
3.3.1. Missing HttpOnly Flag From Cookie (http-cookie-http-only-flag)
Description:
HttpOnly is an additional flag included in a Set-Cookie HTTP response header. If supported by the browser, using the HttpOnly flag
when generating a cookie helps mitigate the risk of client side script accessing the protected cookie. If a browser that supports HttpOnly
detects a cookie containing the HttpOnly flag, and client side script code attempts to read the cookie, the browser returns an empty
string as the result. This causes the attack to fail by preventing the malicious (usually XSS) code from sending the data to an attacker's
website.
Affected Nodes:
Affected Nodes: Additional Information:
xx.xxx.xx.xxx:443 Running vulnerable HTTPS service.
https://xx.xxx.xx.xxx/owa/
1
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
raigjCommented:
Did you figured this out already.. If you did can you help and post your solution. thank you.
0
 
raigjCommented:
Thanks.
0
 
jtanoAuthor Commented:
Did not get an answer
0
 
jr2911tinklerCommented:
Hello - been sufferring through some similar issue in responding to pen test results.

No expert mind you but did you try the below in web.config for the application?
<configuration>
  <system.web>
      <httpCookies httpOnlyCookies="true" requireSSL="true"/>
  </system.web>
</configuration>
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.