Hub Transport server role can not resolve DNS name of Edge transport server role in DMZ

Set up two Exchange 2010 servers / Windows Server 2008 R2 SP1

1. Edge tansport server role in DMZ (10.0.0.X) (Two NICs - one is for 10.0.0.X, the other one for 192.168.2.x)

2. Hub transport /CAS/Mailbox server inside LAN/Domain (192.168.2.X)

I have no problem to resolve DNS name of Hub/CAS/Mailbox server role from Edge transport server role but
can not resolve DNS name of Edge transport server role from Hub/CAS/Mailbox server role.

In short (DMZ -> LAN) DNS name resolution - no problem
(LAN -> DMZ) requested timed out. (All ports are open in LAN -> DMZ)

Host file has been created, A record is added, DNS server set up is all according to Microsoft TechNet paper instruction.

I can't perform Edge Subscription unless I know they (Edge/Hub) can resolve DNS name for each other.

Any ideas? Please help.
City_Of_IndustryAsked:
Who is Participating?
 
Hendrik WieseInformation Security ManagerCommented:
Have you got any other machined in the dmz that is visible or accessible from your LAN? If so are they in the same address range as you Edge server? Have you enabled ICMP on the edge server to see if you can ping it?
0
 
Madan SharmaConsultantCommented:
r u able to ping the edge server from hub server by IP if yes then try nslookup ip of edge server and see whats its returning in response.

Also make sure you have create reverse dns zone on your dns server.
0
 
City_Of_IndustryAuthor Commented:
Thank you I forgot to open ICMP in Edge server, actually they resolved to each other already.
Currently ICMP and nslookup work fine in both server role.
0
 
danieldriggersCommented:
I am having the same error. however, none of firewalls are turned on. I can nslookup by the IP address but not the FQDN. I can nslookup the FQND of the Exchange Server from the Edge server, but not vice-verse. Both machines can nslookup each others IP address. I tried editing the hosts file but it did not work.

My Edge server has an IP in the range of the domain on the domain network segment, and also has a 10.10.10.0/24 IP address for the DMZ. The server is not joined to the domain, it sits in a work group.

My Exchange servers is in the domain and has a static IP assigned.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.