Internet explorer security

The morning all of a sudden I am getting asked the question " some of this page was delivered in https. do you wish to view only the secure content delivered to this page? If you say no your security may be compromiised"  What I wish to do is disable that question box.
It is happening with every mouse click I do on all my banking sites as I move from page to page i get the small dialoge box with the question and I must answer Y or N before I can proceed to next page.   I am running XP PRO SP3

MY QUESTION IS: can someone please show me how to disable that dialogue box , STEP BY STEP PLEASE ?  It is the most annoying thing I have ever come across becuz it happens with each click     The only thing I might have done differently is that yesterday tthere was an unusual amount of MS updates and I have been away from computing so long (illness) that I forgot how to navigate to MS updates.  all i can do now is emil and banking.  frankly I miss all you guys and gals for the last 9 months.  The primary zone I chose is mentioned in the box.  i think something about part of

Thanks in advance,

Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

btanExec ConsultantCommented:
Welcome back Donnie616. :)

Before disabling just to be aware of IE does that to blocks non-secure content (by default for IE 9 in Win7 and VISTA) and is set to prompt you when this is happening. Changing this setting may make your computer vulnerable to viral, fraudulent or malicious attacks. Of course, Microsoft does not recommend that you attempt to change this setting. So be extremely wary as you modify this setting.
To Disable/Enable/Prompt the “Only secure content is displayed” message:

Start Internet Explorer.
On the Tool menu, click Internet Options.
Click the Security tab, and then click Custom level.
In the Settings box, scroll down to the Miscellaneous section, and under Display mixed content choose from the following options:
>Disable, will not display non-secure items.
>Enable, will always display non-secure items without asking
> Prompt, will prompt you when a webpage is using non-secure content

There is also another option (good to know) if there is mix of content (page contains both secure and nonsecure items.) -
Donnie616Author Commented:
Thank you both.  I chose to "enable" mixed content like the instructions say but as i made the change while on the log in page to my banking site, The padlock dis appeared from site right before my eyes. both your answers solved the problem of the annoying dialoque box but created another issue. Yhat lock is gone and I dont like that either.Got to go to bed now but will check in early in am.  thanks to you both.

D. So how can I get rid of theat box but be safe at teh same time ___Like it was before i did these last few updates.
Put Your Flow Data to Work

SolarWinds® Flow Tool Bundle combines three easy-to-download, easy-to-use flow analysis tools that can help you quickly distribute, test, and configure your flow traffic.

btanExec ConsultantCommented:
Actually for mixed content by removing the prompt, the agreement would be to suppress the need for https for secure content, hence lock disappear. It happened for mix content website. See this for more info, that is the choice of dropping https when enabling it...

Preferably we go for disable instead to have secure. It may break some site though, but compared to being compromised and exposed, it would be preferable. See this
Donnie616Author Commented:
Breadfan, thank you.  i will research your reccommends and get back to u later.  cant do it now, but i am still afraid to be compromised on the bank site.
btanExec ConsultantCommented:
Sure. Secure by default - Go for IE protected mode and even private browsing to layer the defends. Go for the latest version. There is also NoScript for other browser to stop javascript from running which is typically the exploit point, and you may feel user unfriendly (you need to manually enable script to run for a website) but it is secure

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Donnie616Author Commented:
Not an easy answer because it involves making a decision on my part.

It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.