Windows 2008 Firewall

Hi

In our environment we have enabled the windows firewall in windows 2008 servers.  After that we are not able run any VB script against those servers. What are port required for VB script using WMI and which port psexec use?
valuelabs97Asked:
Who is Participating?
 
rishabv1Commented:
445 and 139

You can use netsh command for creating port exceptions:

Netsh firewall add portopening
                   [ protocol = ] TCP|UDP|ALL
                   [ port = ] 1-65535
                   [ name = ] name
                   [ [ mode = ] ENABLE|DISABLE
                   [ scope = ] ALL|SUBNET|CUSTOM
                   [ addresses = ] addresses
                   [ profile = ] CURRENT|DOMAIN|STANDARD|ALL
                   [ interface = ] name ]

netsh firewall add portopening TCP 80 MyWebPort
netsh firewall add portopening UDP 500 IKE ENABLE ALL
netsh firewall add portopening ALL 53 DNS ENABLE CUSTOM 157.60.0.1,172.16.0.0/16,10.0.0.0/255.0.0.0,LocalSubnet
netsh firewall add portopening protocol = TCP port = 80 name =MyWebPort
netsh  firewall add  portopening protocol = UDP port = 500 name = IKE mode = ENABLE scope = ALL
netsh  firewall add portopening protocol = ALL port = 53 name =DNS mode = ENABLE scope = CUSTOM addresses = 157.60.0.1,172.16.0.0/16,10.0.0.0/255.0.0.0,LocalSubnet
0
 
davorinCommented:
For psexec you need ports 135 and 445.
For WMI please look here:
http://msdn.microsoft.com/en-us/library/windows/desktop/aa822854(v=VS.85).aspx
0
 
valuelabs97Author Commented:
davorin

Thank you. Will there be way to check what and all the ports enabled in a server
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
valuelabs97Author Commented:
Hi davorin,

Even I included the WMI in the exception list, I am not able to connect the server remotely.
0
 
rishabv1Commented:
Have you added RPC port?
0
 
valuelabs97Author Commented:
Hi rishabv1,

I added RPC port too
0
 
davorinCommented:
Sorry for long delay.

Example of command user to show all rules (ports) open in inbound direction:
netsh advfirewall firewall show rule name=all dir=in

At the end you can add profile=domain to list only open ports at domain firewall profile. Other options are public and private.

For checking FW state for WMI should work:
netsh advfirewall firewall show rule name="WMI"

Are you opening this ports in network profile the server is using?
0
 
valuelabs97Author Commented:
Hi davorin
 
Sorry for long delay

I have opened the ports. Still we are facing the same issue.

0
 
valuelabs97Author Commented:
I tried the solutions but we are no longer working on this now. Hence abandoned this Thanks for the everyone's efforts on this
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.