Google Chrome no longer works with any .crx (themes and extensions) on public computers

Hello Everyone,

I use Google Chrome on Public computers (windows XP) where I don't have admin rights. Google Chrome 16 works perfectly fine EXCEPT if I try to install any themes/extensions. Basically what happens is, I click to install a theme, it downloads a .crx file, and then does nothing. The .crx file stays on my computer and nothing is done. Other than that Chrome works totally fine as far as I use it so far.

Google Chrome 13 used to work perfectly fine, if I wanted to install a theme, it would download a .crx file, the .crx file would automatically be processed, the theme would be installed, the .crx file would be automatically deleted and all would work perfectly fine.

Please help
adkryAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

2toriaCommented:
Seems to be a common problem for many - there are some possible solutions here on this forum, but other than that I'm not sure why this would happen.  Have a look and try some of the suggestions out:-

http://www.google.com/support/forum/p/Chrome/thread?tid=6f7260cddadafb82&hl=en

HTH,
Matt
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
adkryAuthor Commented:
The problem is, everything works perfectly fine when I run it on a virtual server (windows server 2008) where I have admin rights
0
2toriaCommented:
Then I would assume that is your problem, but not sure why it's happening - did any of the solutions in the forum I linked help at all?

Matt
0
adkryAuthor Commented:
I don't why Chrome would need admin privileges, since it doesn't require admin privileges to fully install (not portable)

This is the only solution which worked for me,

"This is an annoying step to take but it worked for me as I still have the issue of the CRX file being downloaded.  If you rename the CRX file to a zip file you can extract it to a directory and then when you go to chrome://settings/extensionSettings check the box that says "Developer Mode".  Once you check that box you will get a button that says "Load unpacked extension"... Click that and point it to the directory you extracted the CRX file into.

NOTE: Some zip programs including WinZip and OSX's built in unzip program do not work correctly with this method.  If you are on a Windows machine use 7-zip... if you are on a Mac you will need to go into a terminal window and issue the command "unzip extension.zip" in order to unpack it." - bblboy54 "!

but 1- it's very annoying, 2- the extension folder needs always to be in the same directory, which is even more annoying

Anyone else has suggestions?
0
adkryAuthor Commented:
Any other suggestions please ?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Development

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.