Possible problem in Oracle/Vb.net application

We have an application Oracle as back-end with Vb.net as front-end is working fine since 1 year but before 1 week the application give me an error message "Cannot connect to database".

The both database and application available in same client machine - Windows xp

What the possible problem here ?

Why the application not connect the database ?
egovernmentAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

slightwv (䄆 Netminder) Commented:
What changed?  Please don't say nothing.  Things that used to work do not just stop.  Something has changed.


Is there an Oracle error number?  They should start with ORA- and have a 5 digit number.

Did the XP Firewall settings change?  For grins, turn off the firewall and see if the problem continues.
0
egovernmentAuthor Commented:
Hi slightwv

I'm looking first time what the primary checking I should do.
0
slightwv (䄆 Netminder) Commented:
first thing is you need a better message form the application.  Did it produce an Oracle message?  Does it write log messages anywhere?

Did shutting down the firewall work?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

OP_ZaharinCommented:
- does the database is up and running? the services is running? have you tested to connect to the database using sqlplus/any GUI tool?

- are you using odbc? check/test your odbc able to connect to the database.
0
egovernmentAuthor Commented:
This is oracle services is fine ?
Oracle-services.bmp
0
egovernmentAuthor Commented:
Maybe the problem with

ORACLEorahome92TNSLIstener

If I try to start it but it's not working but there no error message comming
0
slightwv (䄆 Netminder) Commented:
>>ORACLEorahome92TNSLIstener

Well, you need a listener running.  If you do not have any others then yes, this is likely the issue.

From a command prompt post the results from:
lsnrctl start
0
egovernmentAuthor Commented:
I re-start the listener and re-configure the services
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
egovernmentAuthor Commented:
My answer the correct
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Visual Basic.NET

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.