Slow Performance with IIS 7.0 and Integrated Windows authentication and ASP

We are running IIS 7.0 with Integrated Windows and Digest authentication and we are using active service pages.  When our users are trying to access a web page that requires authentication it runs very slow, atleast 20-30 seconds before the pages would display.  This happens know matter if it windows 7 or XP, Firefox or IE.

I have follow the instructions in Microsoft article id 954873 and things are still slow.  Any other suggestions.
mobotAsked:
Who is Participating?
 
e_aravindConnect With a Mentor Commented:
Just curious: Is the situation better without the "Digest Authentication"

IMO, if the windows-authentication fails for the web-client (browser) then the basic-auth. prompt should be presented to the users...so what is the exact\actual need of the "Digest Authentication"?

0
 
Paul MacDonaldConnect With a Mentor Director, Information SystemsCommented:
Are there any errors in your Event Logs?  Is there a domain controller on the same network as the web server(s) ?
0
 
mobotAuthor Commented:
There are nothing related to IIS or authentication in the event logs.  Yes, they are all part of the same domain.
0
 
mobotAuthor Commented:
Problem solved by rewriting asp code in asp.net
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.