Join not functioning in MS Access

The attached image shows a very basic setup for a query that for some reason is failing to make the join this query brings back nothing from the PDM_CDM_LISTING table when clearly there is at least one join which should be recognized. The tables are nothing special and all fields are TEXT.

I'm puzzled......

Thanks for your help.

when i say 'blank' in the image i mean no data from PDM_CDM_LISTING is showing


Query-Miss-Fire-Dec2011.png
markloessiAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rey Obrero (Capricorn1)Commented:
what happens if you choose option1?
does the query return any records?
markloessiAuthor Commented:
The results are blank with Option 1
Rey Obrero (Capricorn1)Commented:
try this
* delete the query
* do a compact and repair
   tools > database utilities > compact and repair


now, create the query

post back the result
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

dqmqCommented:
Can you see the problem in SQL mode?   If not, post it here.
markloessiAuthor Commented:
OK, discovered something. Compact / Repair didn't work. But checking the tables I discovered that the CDM_ERROS values in the EPIC_interfaceTest_CDM_Failures table have a leading space (on the left).

So I tried 'CDM : TRIM([CDM_ERRORS])' but this didn't work, syntax? or just wrong tree :)

Query-Miss-Fire-Dec2011-img2.png
Rey Obrero (Capricorn1)Commented:
back up table first, run this update query,

update EPIC_interfaceTest_CDM_Failures
set [CDM_ERRORS]= Trim([CDM_ERRORS])

now test the query

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Rey Obrero (Capricorn1)Commented:
if the above update query did not correct the field, try this one

update EPIC_interfaceTest_CDM_Failures
set [CDM_ERRORS]= Mid([CDM_ERRORS],2)

or better upload a copy of the db so we can see what the value of the leading character in field [CDM_ERRORS]
markloessiAuthor Commented:
This worked. Thanks heaps!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server 2005

From novice to tech pro — start learning today.