Set up did not find any hard disk drives installed on your computer

I have an old Dell and at the moment the system is linux Fedora I think.

I want to change this to xp but find I cannot, please see title.
I started themachine with XP Pro in the CD drive.

I pressed F2 and entered the setup
Changed this to read
1      Onboard or USB CD-ROM drive
2      Onboard SATA Hard Drive
3      Orboard or usb floppy Drive      

Press esc and save to exit

Windows set up appeared next
Setup is loading files

Setup is starting windows

select Set up Windows XP

Then the screen announced
Set up did not find any hard disk drives installed on your computer

Setup cannot continue.

Can anyone please advise what I may be doing wrong?

Many thanks

John
johnhardyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Richard ColeCommented:
Are you using SATA drives?  If so, have you tried to set them to legacy mode?
You may need to load drivers (F6 when set-up starts) to get WinXP to recognise the drives.
0
Michael_MCDSTCommented:
It is possible that the hard drive, the cable for the hard drive or the motherboard is defective.
First try reseating all of the devices to the motherboard and ensure that the hard drive cable is placed in the correct slot.
0
☠ MASQ ☠Commented:
This is a driver issue, XP doesn't natively recognize SATA hard drive
controllers.

You either need SATA drivers for the controller on the laptop
slipstreamed onto your installation CD or the BIOS ability to switch
AHCI mode to PATA emulation.

It'll help to know which model of laptop.
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

johnhardyAuthor Commented:
Thanks
This is not a laptop its an old dell Precision 380.

It is running Fedora OK so I imagine the drives and board is working
0
Wayne BarronAuthor, Web DeveloperCommented:
Hello John.
I have to run out, so this should get you started, once you have this current issue taken care of, take a look at the following article that I wrote.
It was done quickly, but should have all the information that you need to do what you need to do.

How to perform a clean install of Windows XP
http://kb.cffcs.com/Main.asp?irid=153&Type=Article

Good Luck
Carrzkiss
0
yaro137Commented:
I'd support MASQUERAID solution. You should find that option in your BIOS
0
johnhardyAuthor Commented:
Thanks Yaro137
I regret to say my knowledge re the statement fom MASQUERAID
"You either need SATA drivers for the controller on the laptop
slipstreamed onto your installation CD or the BIOS ability to switch
AHCI mode to PATA emulation".
Is just about zero.
I have had a look in the bios for the word AHCI but cannot see it
The headings in the Bios are
System
Drives
Onboard devices
Video
Performance
Security
Power Management
Maintenance
Post Behaviour
====================

I notice in the Drives heading list  I have
Diskette Drive
Drive 0: SATA-0
Drive 1: SATA-1
Drive 2: SATA-2
Drive 3: SATA-3
Drive 4: PATA-0
Drive 5: PATA-1
* SATA Operation
* SMART Reporting
Maybe this is related?
0
☠ MASQ ☠Commented:
Sorry, it's difficult to guess prior experience.

Does your 380 have a floppy disk drive?
Are you using a Dell reinstallation CD? (these usually have the driver in question pre-installed)
It doesn't look like switching modes in the BIOS is possible.
0
Gary CaseRetiredCommented:
Switching to legacy mode is almost certainly possible.

Look carefully at each of the submenus in the BIOS.    You should see a "SATA mode" setting, or perhaps "Disk mode".    Different BIOS implementations label these differently, but what you need is to set the SATA ports to "legacy" or "IDE" mode.

The setting will be under System, Drives, or Onboard Devices ... so look carefully at the choices in those areas.     And it probably will NOT say "AHCI" anywhere -- just look for "SATA Mode" or "Disk Mode"
0
johnhardyAuthor Commented:
Thanks MASQUERAID
Does your 380 have a floppy disk drive? Yes

I found a Dell reinstallation CD For XP Home Edition including Service Pack 1
also a
Resources CD
Contents
Device Drivers
Diagnostics and Utilities

Would these help. I am trying to instal XP pro.
0
☠ MASQ ☠Commented:
There's a good chance the reinstallation disk will do this on its own just boot to it and see.  If not having the FDD means it should be quite simple to add the SATA drivers you need.
0
Gary CaseRetiredCommented:
I looked at the manual for your system on Dell's site.

In the System Setup screen (BIOS), highlight Drives and press Enter.

Then highlight SATA Operation and press Enter.

It's not clear in the documentation exactly what options are then available ... just press the left & right arrow keys to scroll through them.   What you want at this point is "legacy", or "IDE" mode.    If neither of these are among the choices, list the choices here.

The other alternative is to get the SATA drivers on a floppy disk;  then use that disk with the F6 option to install 3rd party drivers.     To do that, you'll need to create a floppy with the appropriate drivers -- which should be available on the Dell Resource CD (or you can download them from Dell's site).    Masqueraid is pointing you in the right direction for this option.

Note that if you simply change the SATA mode in the BIOS you won't need the drivers -- and the system will still work fine and at full SATA interface speeds.


0
johnhardyAuthor Commented:
Thanks for the information

I followed the Garycase method and on the SATA Operation took a pic of the screen which I attach.

I hope this is clear enough

 Sata
0
☠ MASQ ☠Commented:
Combination is the option you're looking for, but try booting from the Dell CD first and see if that detects the drive without needing to add additional drives or changing the settings.  If that doesn't work then go for the combination option.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
johnhardyAuthor Commented:
Thanks MASQUERAID

I tried to use the reinstallation disk but it caused an error

File \i386\ntkrn1mp could not be loaded
the error code is 7

 
0
johnhardyAuthor Commented:
I next received this error:

File \i386\biosinfo.inf could not be loaded
The error code is 2
Seems like the reinstall has given up the ghost

Its now failing whether I use the XP program disc or the Dell Reinstallation CD
0
☠ MASQ ☠Commented:
Try the combination setting but often the fix for the ntkrn1mp error is to use a different optical drive :(
0
johnhardyAuthor Commented:
Thanks Masqueraid

I did try the combination setting but with no luck

I am suspicious that the CD is not working as I am now getting
Selected boot device not available, next problem I dont have a spare.
0
Gary CaseRetiredCommented:
The combination setting should work.

What CD are you trying to boot from?    It should be the "Dell reinstallation disk for XP".

... and are you pressing a key when it prompts to "Press any key to boot from CD" ??
0
yaro137Commented:
Looking at your screenshot I still think you're in the right place just try various options if the selected one doesn't work. I had this problem myself some time ago with a dell PC. You shouldn't need any drivers for SATA. If you had RAID enabled it would be a different story.
0
yaro137Commented:
Also make sure in the options above the highlighted one your drives are turned ON
0
johnhardyAuthor Commented:
Thanks yaro137
I hope to get another CD player on Friday so will see if that is any different
0
d4durveshCommented:
This error will appear most often when your hard disk is on an SATA or SCSI controller and Windows setup does not have a suitable driver.

In most cases these days you won’t have a floppy disk either to load the drivers.

There are a few ways to deal with this ranging from the very simple
(hopefully says you!) to the long and somewhat difficult. See the solutions below for more.

Solution 1 – Set Your SATA Controller to Compatability/IDE/Standard Mode

   1.Enter your BIOS/Setup Utility
    2.Locate the Serial ATA or SATA configuration section
       > I’ve seen this section called ‘On Chip Config’ on some Phoenix Award BIOS
       > On Lenovo/IBM ThinkPads it’s in Config > Serial ATA (Sata)
   3.Change the mode of the SATA controller from AHCI to IDE or Compatibility
   4. Save & Exit
   5.Reboot and begin the Windows Setup again.
   6.If Windows Setup successfully detects your hard disk this time then go ahead and perform the Windows Setup.
   7. When Windows setup completes change the mode back to AHCI in the BIOS
   8. If your problem still exists after changing this option then change it back to AHCI and proceed to Solution 2 below.

Solution 2 – Load your SATA drivers using a Floppy Disk (or CD)

– Create A Custom Windows XP CD with your SATA drivers as an alternative to using a floppy disk.  If you need help finding your SATA drivers see the article How To Find Your SATA Drivers

     1.   If you already have a floppy disk drive in your computer then great, proceed to Step 2. If you don’t, click here to get one
      2.  Go to either your computer manufacturers support website or if you have a custom build then go to your mainboards manufacturers support website and download the SATA driver package. Some popular manuafacturers are listed below:
       >     HP/Compaq Support
        >    IBM/Lenovo Support
         >   Dell Support
       3. Extract the downloaded driver to a blank floppy disk
       4. DO NOT insert the floppy disk into the computer that you are attempting to run Windows Setup on
       5. Insert your Windows XP CD and start your computer, press any key to boot from CD if requested
      6.  As soon as the blue setup screen appears press F6 on your keyboard. The message to press F6 will disappear and be replaced by a message requesting you to press F2 for ASR. Do NOT press F2.
      7.  After the “Setup is loading files” part is complete you will be presented with the screen below
      8.  Insert the floppy disk you created and press S to Specify Additional Device. Windows will load your driver and you see

 Screenshot of detail
0
johnhardyAuthor Commented:
Thanks everyone for all the help, I wish there were more points to award!

I think in the end the problem was tracked down to a small connector block at the rear of the CD case was placed in Slave and it should have been placed in Master.

Anyway it seems to be working correctly now.

Big relief!

My thanks again

John
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.