Activesync stopped working Exchange 2003 Server

I have a Windows 2003 server running Exchange 2003.  I had Activesync up and running without problems.  We had a long power outage on Saturday and when the server came back up Activesync would no longer work.  No one with email set up on their phones can connect to the server.  I have since restarted the server and still no luck with Activesync.  

I used the Access My Lan Activesync tester and it fails under verifying certificate and user permissions.  It says ActiveSync detected, but not enabled. [ActiveSync disabled globally or for this user?].  I checked and activesync is globally enabled and enabled on the user level as well.  

In the Event Logs there are a ton of Event ID 3012 Activesync errors that say: An error occurred while accessing the Active Directory for user [Internet Guest Account]. Information cannot be retrieved from Active Directory due to an unknown error. Verify that the Exchange ActiveSync Server can communicate with Active Directory, and that the user has a valid account.

I’m not sure what happened.  Everything was working fine before the server went down because of the power outage.  Normal mail and OWA is working fine.  Any help is appreciated.  Thanks.
hbmonlineAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mumbaiexpertsCommented:
Hi,follow this article ,
http://support.microsoft.com/kb/937635
Resolve your problem
Thnks.
hbmonlineAuthor Commented:
I followed the article and made a couple changes but still no luck.  The article refers to SBS server which I'm not running so I'm not sure if that makes a difference.  I'm no longer getting a "ActiveSync detected, but not enabled. [ActiveSync disabled globally or for this user?]" error in the ActiveSync tester but now I"m getting "ActiveSync detected, but not correctly configured. [HTTP 500: Forms-based auth enabled?]".

Now in the event logs I'm getting Activesync Event ID 3005 which says: Unexpected Exchange mailbox Server error: Server: [server-name.domain.local] User: [username@domain.net] HTTP status code: [400]. Verify that the Exchange mailbox Server is working correctly.
mumbaiexpertsCommented:
Hi follow this link resolve your solution:
First you take the backup of IIS and then follow this link you will resolve your issue.
http://technicians-blog.kingcomputer.com.au/active-sync-error-eventid-3005-unexpected-exchange-mailbox-server-error/
thnks
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

hbmonlineAuthor Commented:
Unfortunately that did not work either.  I'm still getting the same errors in the Event Logs.  
hbmonlineAuthor Commented:
Ok, I just found something that may be the problem.  I compared this mail server to another one I have and the problem server does not have Exchange-oma in IIS at all!!!  How could that directory have vanished?  
hbmonlineAuthor Commented:
Well, after some more looking, the missing exchange-oma virtual directory may not be the problem.  I'm still beating my head against the wall on this one.
hbmonlineAuthor Commented:
If I try to browse to http://servername/oma on this server I only get a "The website declined to show this webpage" message.  I double checked the permissions on OMA in IIS against a known working mail server and the settings are identical.  Any suggestions?
hbmonlineAuthor Commented:
Found this KB that may be a solution.  http://support.microsoft.com/?kbid=883380

Will not be able to try until tonight after hours since it will require the server to be restarted.  Has anyone else found this article to be a solution?
hbmonlineAuthor Commented:
I recreated the Exchange directories in IIS following the article and it did not fix the problem.  Still same activesync errors.  Can anyone think of something more for me to check?  
hbmonlineAuthor Commented:
Now I have the following error when attempting to browse "http://servername/oma":
Server Error in '/OMA' Application.
--------------------------------------------------------------------------------

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: The 'mode' attribute is case sensitive and must be one of the following values: On, Off, RemoteOnly.

Source Error:


Line 76:               <error> tags for each of the errors you want to handle.
Line 77:       -->
Line 78:             <customErrors mode="off" />
Line 79:             <!--  AUTHENTICATION
Line 80:               This section sets the authentication policies of the application. Possible modes are "Windows", "Forms",
 

Source File: C:\Program Files\Exchsrvr\OMA\Browse\web.config    Line: 78


--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:1.1.4322.2443; ASP.NET Version:1.1.4322.2407
hbmonlineAuthor Commented:
Finally got it fixed.  After going in and changing the web.config line from "off" to "Off" (case sensitive) I was able to see the true root of the problem.  Somehow the ASP dll got unregistered.  After following this KB http://support.microsoft.com/kb/823379, the problem was fixed.  Now OMA is working again and I can access the /oma directory from a web browser without error.  

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
hbmonlineAuthor Commented:
Found the problem and solution on my own.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.