Cannot deploy MSI package with Group Policy

I am trying to deploying an .MSI package to our network clients and am having a problem.  If I publish it under "User Configuration" ->"Software Settings, Software Installation, it becomes available under ->Control Panel ->Programs, Install from Network.

However, I want this program to automatically install for all users of every machine (this is a school so there are many).  I've tried creating the package under "Computer Configuration", Software Setting's->Software Installation" and assigning it.  However when I do this nobody receives the package.

Any ideas.  The shared network location of the MSI package is shared with Everyone.
LVL 1
jchismarAsked:
Who is Participating?
 
kcoectCommented:
Have you tried the following:

1) Verify that the machine is processing Group Policy properly?  If it has problems processing group policy then your software may not deploy properly
2) Have you logged in as an administrator on the machine and run a 'gpupdate /force' to force the machine to update its policy and see the new software deployment?  If it does, then the machine will as to reboot to install the software.

Usually I find the issue to be with a machine not processing group policy properly.
0
 
bill_lynchCommented:
Make it a computer policy.  The computers will need rebooted before they will get the new policy and install the software.  a gpupdate /force before the reboot is recommended.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
jchismarAuthor Commented:
It now seems to be working on my Windows XP machines, but it has not taken on any of our Windows 7 machines.  I tried the gpupdate /force as on here as well, but it is not working.

Component Name Status Last Process Time
Group Policy Infrastructure Success 12/20/2011 3:03:48 PM
Registry Success 12/20/2011 3:03:46 PM
Security Success 12/20/2011 3:03:48 PM
Software Installation Pending 12/20/2011 3:03:48 PM
Software Installation did not complete policy processing because a system restart is required for the settings to be applied. Group Policy will attempt to apply the settings the next time the computer is restarted.

Additional information may have been logged. Review the Policy Events tab in the console or the application event log for events between 12/20/2011 3:03:48 PM and 12/20/2011 3:03:48 PM.
 

System restart does not work... software is not being installed.
0
 
bill_lynchCommented:
0
 
hot_powerzCommented:
You can check event log which will give you the error message.

You can also try to launch it directly after login to the desktop.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.