IPHONE fails to sync contacts Exchange 2003 SBS2003

Have a user that can sync everything on their Iphone except contacts. Contacts are present in OWA. Calendar, reminders, and email sync fine contacts fail to sync.
LVL 17
WORKS2011Austin Tech CompanyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jrhelgesonCommented:
Sounds like a mailbox folder issue.

Unfortunately, you have to dismount the store to run the test.

Dismount the private mailbox store:
(Assuming you have the exchange server /bin files added to your path)
From the command line,
ISINTEG -s {severname} -fix -test ALLTESTS
-or-
ISINTEG -s {severname} -fix -test ALLFOLDERTESTS
-or-
ISINTEG -s {severname} -fix -test FOLDER

On Exchange 2010, you can run those tests with the mailbox online - with 2003 & 2007 you need to dismount the store.

If it were me, I'd just run the 'All Tests', it takes an hour or less to run.  The subsequent tests (AllFolderTests / Folder) will be faster to run and complete, but might miss some problems.

In the isinteg results, you'll see all the fixes done to the database, if you have any errors or warnings, you'll want to re-run the test until they are all gone. (You won't have to, but do not run the test more than 3 times though, per Microsoft instructions)
0
WORKS2011Austin Tech CompanyAuthor Commented:
Ran the testes with the following results, test reference count verification results: 0 errors; 0 warnings; 5 fixes; 0 rows.

Still having the same problems.
0
Alan HardistyCo-OwnerCommented:
Presumably you have Contacts selected on the iPhone to sync?
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

WORKS2011Austin Tech CompanyAuthor Commented:
yes, very strange that everything works fine only contacts won't sync.

No error on the phone and contacts show up in OWA.
0
Alan HardistyCo-OwnerCommented:
Can you add a second Exchange account to the phone and see if that syncs those contacts please.
0
WORKS2011Austin Tech CompanyAuthor Commented:
I created a new account and get the following error: Your Microsoft Exchange Server account does not have permissions to synchronize with your current settings. Contact your Exchange Server administrator.

This error happens on both accounts now, new and old. I verified Active Sync is enabled.
0
Alan HardistyCo-OwnerCommented:
Do you have another iPhone that you can try to sync the same account to?
0
WORKS2011Austin Tech CompanyAuthor Commented:
iphones already connected work just can't update contacts. New devices get the above error.

After running an active sync tester  we now get the following error: ActiveSync detected, but access denied. [HTTP 403: Disabled for this user]

strange error, seems like nothing should work but everything works except contacts on phones already connected, new phones get the "Your MS Exchange Server account does not have permissions to synchronize with your current settings. Contact your Exchange Server administrator.
0
Alan HardistyCo-OwnerCommented:
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Alan HardistyCo-OwnerCommented:
It might be related to Anti-Virus interference, which is mentioned in my article and there is a registry fix for that (and in some instances, a setting within the AV Application to enable Background Scanning).
0
WORKS2011Austin Tech CompanyAuthor Commented:
went through everything in your article and still have the problem with contacts failing. Everything else (email and calendar) work fine.

Interesting. I read somewhere about running the ICW and leaving the Business Web Site (wwwroot) unchecked so did this and now the active sync errors went away and all active sync failures are gone. I now get this after running active sync test

Testing mail.domainname.com (SSL, On Internet):

Communications:
      Doing DNS lookup on mail.domainname.com  OK (IP address)
      Testing TCP to IP Address port 443 ... OK
SSL Certificate:
      Receiving ................................ OK
      Ensuring not Self-Signed ................. OK
      Verifying certificate .................... OK
ActiveSync:
      Checking for application ................. OK
      Checking version ......................... OK (6.5.7638.1)
      Checking protocols ....................... OK (1.0,2.0,2.1,2.5)
User Permissions:
      Checking "domain\username" ..................... OK

Result:
      ActiveSync IS available.

Active Sync errors resolved (would love to know why including Bus Web Site (wwwroot) caused problems with active sync, maybe another time) anyway now still left with contact failing to update on  iphones.

Your thoughts?  
0
WORKS2011Austin Tech CompanyAuthor Commented:
I get two errors now when contacts fail to sync, not just iphone anymore droids as well.

1st error:
Event Type:      Error
Event Source:      MSExchangeIS
Event Category:      General
Event ID:      9667
Date:            12/21/2011
Time:            8:17:42 AM
User:            N/A
Computer:      computer name
Description:
Failed to create a new named property for database "First Storage Group\Mailbox Store (server-name)" because the number of named properties reached the quota limit (8192).
 User attempting to create the named property: "SYSTEM"
 Named property GUID: 71035549-0739-4dcb-9163-00f0580dbbdf
 Named property name/id: "AirSync:MMS"

2nd error:
Event Type:      Error
Event Source:      Server ActiveSync
Event Category:      None
Event ID:      3005
Date:            12/21/2011
Time:            8:15:47 AM
User:            
Computer:      computer name
Description:
Unexpected Exchange mailbox Server error: Server: [computer-name.abc.local] User: [name@domain.com] HTTP status code: [500]. Verify that the Exchange mailbox Server is working correctly.



0
WORKS2011Austin Tech CompanyAuthor Commented:
I uninstalled the AV for troubleshooting purposes, unless there is something left behind in the registry AV shouldn't be the problem.
0
Alan HardistyCo-OwnerCommented:
Please have a read of the following blog regarding the Event ID 9667 errors (can't find the MS article):

http://msexchangeguru.com/2009/09/04/event-id-9667/
0
WORKS2011Austin Tech CompanyAuthor Commented:
I resolved the event id 9667 and now everything is working fine.

Thanks for all the help with this.
0
Alan HardistyCo-OwnerCommented:
Excellent - great news.
0
WORKS2011Austin Tech CompanyAuthor Commented:
alan I'm going to open a new ticket but wanted to touch base with you first since your article resolved the problem I had, great article by the way.

Ever since we got the iphones working now Outlook 2010 won't connect using RPC over http. Any ideas what changed?
0
Alan HardistyCo-OwnerCommented:
:)

Make sure you have Basic & Integrated Windows Authentication enabled on the RPC Virtual Directory - that is the usual problem (only basic enabled).  If that isn't it - let me know.

Run IISRESET if you make any changes.
0
WORKS2011Austin Tech CompanyAuthor Commented:
only Basic authentication is set and their is a \ in Default domain. I'm going to open a question  named Outlook 2010 fails over http, owa working, SBS2003 w/exchange 2003

thanks alan
0
Alan HardistyCo-OwnerCommented:
Then you are missing the integrated auth.  The \ is fine.
0
Alan HardistyCo-OwnerCommented:
Run IISRESET after adding Integrated Windows and then test again.

Looking for a new question but not seeing one (yet).
0
WORKS2011Austin Tech CompanyAuthor Commented:
just posted question, sorry coffee was calling.
0
Alan HardistyCo-OwnerCommented:
Lousy excuse ;)

Posted in the question.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.