IE7 is moving container over, but looks good in IE8 & Firefox

I have tried everything I could think of to try to get this to look right in both IE7 & IE8, but IE7 just will not center the images.

http://insurance.illinois.gov/home/splash.asp
smitty62Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

COBOLdinosaurCommented:
You are using an HTML5 doctype.  IE7 does not understand it so it is rendering in quirksmode.

If you use a strict XHTML doc type it will probably eliminate the problem.



Cd&
0
smitty62Author Commented:
I went to the W3C website, and this is what they have for strict XHTML doctype, but it didn't work.  Is this the correct one?

http://www.experts-exchange.com/login.jsp?redirectURL=/Web_Development/Web_Languages-Standards/CSS/Q_27504396.html%3Fcid%3D239
0
smitty62Author Commented:
Sorry, wrong cut and paste, I meant...

<!DOCTYPE HTML PUBLIC "-//W3C/DTD HTML 4/01//EN"
"http://www.w3.org/TR/html4/strict.dtd">
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

smitty62Author Commented:
I also tried this, but it didn't work either...

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
        "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
0
smitty62Author Commented:
Is there some way to disable the compatibility mode for the IE8 browser.  We all have IE8 where I work, but if someone has their compatibility mode turned on the page won't work.  Is there a way in the code to turn the compatibility mode off?
0
smitty62Author Commented:
FOUND IT!  I resolved the problem by placing:  <meta http-equiv="X-UA-Compatible" content="IE=8"> directly after the <head> tag and it turns the IE7 compatibility mode off.  Since the page is for the Intra net this will resolve my problems.  Thanks for your help, and sorry about wasting your time.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
smitty62Author Commented:
asdf
0
COBOLdinosaurCommented:
It is never a waste of time if a solution is found.  I knew it had to be something in the head for compatibility.  I'll just add the meta tag to my bag of tricks for next time.


Cd&
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
CSS

From novice to tech pro — start learning today.