iPhones fail to connect to Exchange 2007 build 240.6

Active sync and autodiscover tests at www.testexchangeconnectivity.com succeed. AccessMyLAN's activesync tester works from a computer, but the iphone version fails at "Checking version ... FAIL ActiveSync IS NOT available. (Username or Password incorrect.)" I've entered my password many many times, and reset it on the domain controller, so I'm sure that's not the issue.

When I add my Exchange account to my iPhone, I get, "Unable to verify account information."

Any ideas for what I should check in the server configuration?
kzsigoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Alan HardistyCo-OwnerCommented:
0
kzsigoAuthor Commented:
I am a domain admin, but I use a second account to perform admin tasks. My normal user's "Allow inheritable permissions from the parent to propagate..." box is checked.
0
Alan HardistyCo-OwnerCommented:
Okay - can you try adding another account to your iPhone for a user who also has an iPhone and you know it works.  Should rule out your phone as the issue.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

kzsigoAuthor Commented:
That was a great idea. Another user's email works on my phone.
0
Alan HardistyCo-OwnerCommented:
Okay good.  Can you add your account to their phone?
0
kzsigoAuthor Commented:
I tried adding my account to another iPhone, and I had the same problem.
0
Alan HardistyCo-OwnerCommented:
Okay - can you move your mailbox to another store (create one if you don't have another) please.

Once moved, please test again.
0
kzsigoAuthor Commented:
I created a new storage group with a new mail database, and copied my mailbox to it. Unfortunately, it didn't solve the problem or change the error.
0
Alan HardistyCo-OwnerCommented:
Okay - weird.

So the test on the test site passes for your account but you can't add the account to the phone?

How many characters in the internal domain name?

What settings are you entering into the iPhone?

3rd party SSL certificate or Exchange Self-Issued SSL cert?
0
kzsigoAuthor Commented:
The test site passes, yes. Our domain name is 3 characters, or 9 if you add ".local".

For my settings I use:

email: my email address
server: server A host record
domain: empty, DOMAIN, or DOMAIN.LOCAL
username: my username, or DOMAIN\username
password: my password

We have a godaddy certificate.
0
Alan HardistyCo-OwnerCommented:
The domain should only be the internal NETBIOS domain name, so I would expect to use DOMAIN only.

Username should only be your username not domain\username

Server should be the Fully Qualified Domain Name that resolves to your servers IP Address in DNS, or the IP Address of the server.  The SSL certificate should match what you are using in this field, so if you are using an IP address to connect, the SSL cert should be an IP address, if using the FQDN, then the certificate should also be using the FQDN.
0
kzsigoAuthor Commented:
I was able to add another user's email account to my iPhone, so I don't think the problem is the settings I'm entering.

I added a new user to the same OU as the user who worked, and gave them a mailbox, but adding that user's email account to my iPhone gave the same error.

I'm starting to wonder if something changed in our domain such that accounts created after the change couldn't use ActiveSync, and I happen to be one of the newer users who is affected.
0
Alan HardistyCo-OwnerCommented:
Can you remove the Inherited permissions, apply, then add them again and apply, then test again please.
0
kzsigoAuthor Commented:
I tried it, but it didn't fix the problem.
0
Alan HardistyCo-OwnerCommented:
Hmmm!  Getting very strange.

Have you checked the Exchange Features on your account to make sure that all are enabled?
0
kzsigoAuthor Commented:
Yup, everything is enabled, except Unified Messaging.
0
Alan HardistyCo-OwnerCommented:
Okay - what Service Pack is installed for Exchange and what Rollup?
0
kzsigoAuthor Commented:
My version string is "Version: 08.01.0436.000," is that what you need?
0
Alan HardistyCo-OwnerCommented:
Perfect - that translates to SP1 rollup 10.

You don't have SP2 or any of those rollups (up to rollup 5) or SP3 / rollup 5 for SP3, so I would get updating your server before trying to fix anything.
0
kzsigoAuthor Commented:
This is terribly embarrassing. My muscle memory of my password and what I actually remembered my password to be were one character off, so I kept typing it into my phone wrong. Typing on a touch screen doesn't appear to use muscle memory.

We ended up updating exchange, so thanks for that suggestion.
0
kzsigoAuthor Commented:
This comment should have proved to me that there was a password problem.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
iPhone

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.