• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 98
  • Last Modified:

Smart Phone connection problem to Windows 2003 SBS server

One of my customer has a Windows 2003 SBS server for many years, it has been working fine, the Outlook web access works well also. This server has a Blackbarry server connected to also, most people using Blackbarry to get emails.
Now one of them purchased a Android phone, I tried to connect it to the server, but failed with "Error: fail to connect to Exchange server,Please check Exchange server settings".
Then I tried to connect to the server with my HTC Thunderbolt Andriod phone, same error.
There is no errors the in event log on the server.
This server will be upgraded in a few months, so I did no install SSL certificate on it.
I've set up smart phone access Exchange 2003 server several times before without using SSL, they all worked well. I tried Microsoft Remote Connectivity Analyzer, obviously it shows the SSL error. It does not help a lot because I do not intend to use SSL on the server.
I've searched on the Internet but did not get much help. Can someone help me here?
Thanks a lot in advance!
Jack        
0
urbuddy
Asked:
urbuddy
  • 11
  • 7
  • 3
  • +2
2 Solutions
 
Obi WanFixerUpperCommented:
Hey there UrBuddy

The only real details you need for this is as follows:
youserver.yourdomain.com
your internal LAN domain name(something.local) or( something.lan)

Your username and password - try both methodsusing your username only and the internal Domain name: -

something.local\USERNAME

Take of the option for ssl to test it too,

Hopefully this works

Jamie
0
 
urbuddyAuthor Commented:
Thanks! I never test the internal domain name before.
Let me give a try now.......
0
 
urbuddyAuthor Commented:
Just tried, no luck :-(
On the configuration page, there are 5 entry:
Email address: I tried "username@mydomain.com"
Server address: mail.mydomain.com (this is DNS registered name)
Domain: I tried both mydomain.com and internaldomain.local
Usrename: tried username;  mydomain\username; internaldomain.local\username and intenaldomain\username
Password:: the Windows login password.
I've tried all combination of the above, but still got error "Unable to connect to your exchange serve, ....... contact your Exchange server administrator". I'm the administrator LOL.

0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

 
Obi WanFixerUpperCommented:
Everything seems fine, thats all the settings i would use

Can you check the cert installed, is it out of date (goto https://yrousedomain.com/exchange) ?

You may need to run the internet connection wizard again and generate a new one, since the server is old, this may be the cause, if not, is mobile / owa access enabled on the account in active directory ?

Jamie
0
 
urbuddyAuthor Commented:
I tried https://internalIPaddress/exchange on the SBS server, I got "SSL Connection error";
I also tried https://mail.mydomain.com and https://mail.mydomain.com/exchange, both  got "SSL connection error"
I'm going to try the Internet connection wizard.
Thank you!
0
 
Obi WanFixerUpperCommented:
Oh if thats the case, i have seen in IIS where SBS 2003 just drops of the port 443 on the website settings,

You may want to check that first,

Fingers crossed mate !!

Jamie
0
 
urbuddyAuthor Commented:
I can access the mail without SSL. I would prefer to to not use SSL for now. Is it still require certificate (self signed or 3rd party assigned) even if I choose do not use SSL? The Outlook Web access and mobile are both enabled.
I tried to run Internet and Email connection wizard again, but after the welcome screen, I click on "Next" the screen just closed and nothing happened next.
0
 
Obi WanFixerUpperCommented:
Have you taken the tick off the phone to use SSL ?

Also if you want to use SSL, is the router forwarding port 443 to the server ?
0
 
urbuddyAuthor Commented:
I've tried both with or without the SSL checked on the phone.
Just double checked, the firewall is forwading https to the SBS server.
0
 
Obi WanFixerUpperCommented:
The last thing i can think of is as before in an earlier comment, ensure in IIS (Right click on the default server) and ensure that port 443 is listed for SSL

Outwith that, im at a loss, id really need to see this thing, PM me your number i can give you a call and see if we can progress it further, hang about maybe someone else can pick up on this for you

Sorry :(
Jamie
0
 
urbuddyAuthor Commented:
I looked at the server the certificate services is not installed/configured on the server. If I do not want to use SSL, does this matter?
0
 
Obi WanFixerUpperCommented:
If you can access webmail externally, then no this should not matter
0
 
urbuddyAuthor Commented:
OK, that's what I thought. When I setup a server, usually if the external web access works, then the mobile phone work also. But this time it did not :-(  
0
 
Obi WanFixerUpperCommented:
Sorry mate, over to someone else........ Jamie
0
 
MikeKAtLCSCommented:
Do you have Service Pack 2 installed in the exchange server?
0
 
urbuddyAuthor Commented:
Yes.
0
 
MikeKAtLCSCommented:
If you put the domain name before your username then don't fill in the domain field.  The domain you want there is the internal domain name. Server address is the internet/external address for your server.
0
 
urbuddyAuthor Commented:
Thank you!
Just tried. I left the domain field blank,  tried username with externaldomainname\username; internaldomain\username; username without domain, also tried the external IP address instead of mail.mydomain.com, no luck.
:-(
0
 
James HIT DirectorCommented:
Try this:

 to Settings -> Mail
Click on your account and go to the bottom then press Delete Account
Click on Add Account...
Click on MS Exchange
Type in all information (including domain)
Click Next
After a short wait a new field "Server" appears, type the IP/name of your server there.
Click Next
After a short wait it will say "Exchange account verification failed"
Click Next
Click Save
Click Save
You will then be on the Settings -> Mail screen
Click the account you just created.
Click on Account info
Scroll down to the bottom and you should see "Use SSL" change that to "OFF"'
Keep clicking back until you are out of the settings.
0
 
urbuddyAuthor Commented:
Just followed you instruction,
After I type in the IP or server dns name (iI tried both), I click next, I got error:
"Failed to connect to Exchange server, Please check Exchange server settings"
Click OK, then the screen went back where they were.
0
 
MikeKAtLCSCommented:
Open a browser on your phone and type https://externalservername/exchange or https://externalservername/owa or https://externalservername/oma and let us know how that turns out.  You can also try with http vs https and let us know.
0
 
urbuddyAuthor Commented:
I tried all 3. the error were the same:
"A secure connection could not be established"
I'm pretty sure the certificate on the server is not configured/installed. I'm trying to make it work without SSL.
Thank you!
0
 
R. Andrew KoffronCommented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 11
  • 7
  • 3
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now