Cannot Delete Many Extra Rows

Hi Experts --

I have an Excel Macro that I took over.  The file size is much greater than it should be because there are many extra rows and columns.  I tried going to the first unused row and then'CTRL-SHIFT-DOWN' to select all unused rows, and then choosing 'Delete Entire Row'.  It does not seem to do anything.  I tried deleting one row and still there are the same number of rows.  Is there many more rows than it is showing?  Is there any way to delete them, and the same for the columns (I imagine the same method)?

Thanks for your help.

wander
wander4heat19Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Saqib Husain, SyedEngineerCommented:
Once you delete the rows then save the file, close it and then open it again.
0
wander4heat19Author Commented:
Thanks for the reply.  I tried that and when I re-opened, it was as it was, with the set of rows still highlighted...
0
Saqib Husain, SyedEngineerCommented:
Can you delete your data and post the file?
0
wander4heat19Author Commented:
Actually, when I tried to delete the columns, I think it worked because the color disappeared but the column letters are still there.  I think I can HIDE those to remove them.  As far as the rows though, the color still stays on those row numbers which leads me to believe that the deletion is not occurring.  I am trying to delete all rows that are below the turquoise and to the right of it, I believe starting at column G for column, and row 30 for row.  I want to suppress the row letters and column headers too but I think that is just a HIDE.
test.xlsm
0
jmac01Commented:
You can always check what the actual last cell is by choosing Go To Special from the Find and Select Option on the Home tab in 2007.
Your file is still using all rows on the "Unknown" sheet.

I tried all key methods to remove the "duff" rows but to no avail. Sometimes it just happens and you can't get rid of them. Pretty rare in Excel 2007 and above though. But is this happens, then the only really way to solve it is to delete the sheet. If the sheet is not too complicated to recreate, this can be a quick remedy. But be sure not to copy over anything completely. Always use Copy and PastesSpecial. You can use this to set the column widths, formats and formulas. Don't select the entire sheet when you cop. Just the range being used. This will avoid you copying over the problem that you are trying to remedy.

I would also suggest you clean up your "names" remove all the "Ref" ones.




0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Excel

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.