DNS entry changes back by itself

Hello,

We made some DNS changes yesterday. We are hosting the DNS entries so we edited the settings on DNS on our domain controller server 2003. We deleted the old CNAME record and added the new one then it works for a while  (we can ping and everything) and it changes back by itself to the old CNAME entry.

Let say server1 CNAME server2 and we added server1 CNAME server3 but server1 keeps changing back to server2.

Why is that happening and how can we prevent that from happening?

Thank you in advance!
HD LFAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
is it single server? delete the record first then right click on the DNS -> domain -> scavange steal resource record -> then restart DNS -> create CNAME -> right click update server data files.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
HD LFAuthor Commented:
We have two domain controllers. We are making the changes on the primary domain controller and it automatically updates to the other one.
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
did you do the above steps? do it and tell me the result.
0
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

HD LFAuthor Commented:
I did the steps above and it is working so far, I am going to monitor it and see if it changes again. Thank you.
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
i wish its will work fine , good luck .. if its not working let me know , i will try to figure it out , also check the event viewer -> dns section , see what event raised in-case of the problem back
0
HD LFAuthor Commented:
No, it changed back again :(
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
ok if so then the DHCP server that installed on your server who still have old record , the DHCP keep updating DNS with new records , so what i want you to do is deleting the old record from DHCP and DNS then restart both DHCP server service and DNS Services , this maybe the reason why DNS keep reverting back the old record.
0
HD LFAuthor Commented:
The IP address is not even listed on the DHCP server (not on reservations, nor leases, nor excluded) The problem is that it is changing back to the old dns name and therefore the IP address.
0
HD LFAuthor Commented:
We turned off the server that it kept changing the CNAME to and it has been working fine since yesterday. Thank you for all your help Jordannet
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
that's very nice to hearing that problem been solved.
0
HD LFAuthor Commented:
All the steps suggested helped but the main thing was to turn off the server to avoid the DNS change the CNAME again...I am guessing there is something in the server that kept changing it back.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DNS

From novice to tech pro — start learning today.