Deploying Web Part error

Hi Experts
I am facing a problem in deploying web part in production server, the web part is working perfectly in the sharepoint that is installed in my pc after deploying with no error, now ehn i want to deploy the web part in another server using the prompt comand it gave me the folloiwng error
-------------------------------------------
E:\Migration\Correspondence WebPart1>setup.bat

E:\Migration\Correspondence WebPart1>stsadm -o addsolution -filename Correspondence.wsp

Operation completed successfully.


E:\Migration\Correspondence WebPart1>stsadm -o deploysolution -name Correspondence.wsp -allowGacDeployment -immediate -force -url "http://mofportal"

Timer job successfully created.


E:\Migration\Correspondence WebPart1>stsadm -o activatefeature -name Correspondence_Feature1  -url "http://mofportal" -force

Failed to find the XML file at location '14\Template\Features\Correspondence_Feature1\feature.xml'


E:\Migration\Correspondence WebPart1>stsadm -o activatefeature -name Correspondence_Feature1  -url "http://mofportal" -force

Feature with Id '5c5ee454-0141-4f46-a5b7-8228012d6098' is not installed in this farm, and cannot be added to this scope.
-------------------------------------------

and when i tried to activate the feature manually through the administration i found the following error in Administration and for this deployment it took more than 2 hour and the message didnt canged

can you help me solve this problem,
thank you
LVL 1
AZZA-KHAMEESAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ivan_vaguninCommented:
Hi!
Try to cancel current deployment task, then retract and redeploy solution. Also check that SharePoint Timer service is running. If it does not help try to restart SharePoint Timer service.
0
AZZA-KHAMEESAuthor Commented:
Thank you ivan_vagunin for your reply, i tried redeploy several time and no use also i restart the sharepoint service but still nothing
0
dhawalsethCommented:
I need some background info. Have you used the .bat file to install the solution in your environment? And what is the difference in installations on your environment and production environment setup?
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

AZZA-KHAMEESAuthor Commented:
yes i used .bat file see the attahcment setup.txt and the about the second question i didnt understand it, but the test invironment is the sharepoint installed in my pc as i deployed this web part and its working perfectly, and the production invironment is in another server.
0
ivan_vaguninCommented:
Hi!
Try to deploy package using SharePoint Powershell and web UI instead of stsadm.
Use following SharePoint 2010 PowerShell cmdlet:
Add-SPSolution -LiteralPath C:\MyFolder\Correspondence.wsp

Then go to Central Administration, Solution Management and try to deploy it manuall to your web application.
0
dhawalsethCommented:
Hi Azza,

you need to verify that the feature is added or not. You can use the powershell command directly or use the attachment I am adding with this post. Just change the .wsp name to your solution package and change the url to your application url.
Look for [yourURL]: replace it with your application url
"solutionpackagename.wsp": replace with your wsp name with extension .wsp.

Copy both attachments to the same location, and rename it from .txt to .ps1.

 InstallWebparts-WSP.PS1.txt Wait-for-Solution-Deployment-Job.txt
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AZZA-KHAMEESAuthor Commented:
Thank you
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.