Samba on Ubuntu11.10 server

Hi,
I have been following some CBT on Linux aka( CBTLINUX) the trainer is using Debian 5.
However i installed Unbuntu11.10 server  because i am little more use to Ubuntu still i consider myself a newbie when it comes to Linux.
I follow the trainer and got samba and SWAT install no problem however when i got to part  to view SWAT i only see HOME:STATUS:VIEW: PASSWORD the trainer video show more options.
I put into the browser localhost:901/globals however i am not  seeing all the options available for SWAT that the trainer video show.

I bet a Linux  wizard can figure this out fast.  I don't know whats wrong. I am logged in as ron.

Thanks!




 
LVL 1
rwh01Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jayachandran PalanisamyTechnical Consultant - LinuxCommented:
It might be due to the version of SWAT.

Just have a check here.
http://www.jonathanmoeller.com/screed/?p=3364

You can find the latest version of SWAT here.
http://pkgs.org/ubuntu-11.10/ubuntu-universe-amd64/swat_3.5.11~dfsg-1ubuntu2_amd64.deb.html

To check which version of SAMBA and SWAT installed on your system.
dpkg -l |egrep -i 'samba|swat|smb'

Open in new window


Jay
0
rwh01Author Commented:
Here's screen shot of your command


ron-cw-linux----002.png
0
rwh01Author Commented:
chandranjoy:

Do i have version 3.5.11 according to the screen shot?  I can log into SWAT as user account ron however i don't see all the buttons that SWAT uses.  Will  i try to log as root it won't take.

My root password is correct.
0
Slav ZabickiSystem EngineerCommented:
first do this:
tail -n 0 -f /var/log/messages
and copy and paste a part of the log with swat messages.
find something like:
smb_pam_auth failed - Rejecting User root

backup /etc/pam.d/samba

and

edit the valid file.
try:
auth       include      system-auth
account    required     pam_nologin.so
account    include      system-auth
session    include      system-auth

____________


you may check
/etc/xinetd.d/swat



service swat

{

port = 901

socket_type = stream

wait = no

# Use only_from if you want to restrict access

# only_from = localhost

user = root

server = /usr/sbin/swat

log_on_failure += USERID

disable = no

}



0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rwh01Author Commented:
Thanks to all
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.