trying to complete my setup of exchange 2010 to work with mobile devices (iphone)

I have setup a test server at home to use for testing changes to exchange before implementing them on my sork server.  I just about have everything setup and have gone through the Exchange Remote conectivity analyzer for my domain graf-x-design.com.  Everything is clear except the following with activsync:

Additional Details
Testing HTTP Authentication Methods for URL https://mail.graf-x-design.com/Microsoft-Server-ActiveSync.
The HTTP authentication test failed.
Additional Details

.....................................................................................................................................................
When I go to setup an account on my iphone it tells me: unable to verify account info.  I can save the setup and get 'connection to server failed.  During this troubleshooting I had to make sure that my ISP had unblocked port 25.  They tell me nothing else is blocked at this point. All other services seem to be working fine.  I can log into OWA and send and receive. I can connect to outlook fine.

I have gone into IIS and looked at the auth setting and compared then with my working Exchange server at work and they are identical.  I wish I had a different phone to test this with. I do have an Ipad and it produces the same error.  I have testing internal only and external and get the same error.  I am thinking I may have more than one issue because if I externally browse the URL https://mail.graf-x-design.com/Microsoft-Server-ActiveSync, I get a 503 error service not available.  If I try this internally it appears to see the service.  At home i have a static IP address block so it is not a NAT issue, Autodiscover works fine both internal and externally. I guess I need a better checlist to see what I am missing.
lthorupIT ConsultantAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lthorupIT ConsultantAuthor Commented:
I wanted to add that I am using a iphone 4s with the latest IOS installed.
0
lthorupIT ConsultantAuthor Commented:
Looks like I figured it out .  In the exchange app pool un IIS the Microsoft-server-Activesync app was stuck in a processing mode.  This is why it was giving the web error 503 service not available.  I had to manually kill the process and then start it back up.  I still am a little concerned about why it was having this issue and wondering if it will rear its ugly head again.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Algorithms

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.