Migrated Exchange 2010 accounts cannot send e-mail to Exchange 2003 accounts in same Exchange org

I have an Exchange 2003 Enterprise organization which I am trying to update to Exchange 2010.  I have the Exchange 2010 servers built and was able to move over two accounts from Exchange 2003 to Exchange 2010 (all in the same organization and domain).  The problem I am having is that once one of the mailboxes is moved to Exchange 2010 from Exchange 2003, it can send e-mail to an Exchange 2003 mailbox in the same organization, but it cannot receive e-mail from an Exchange 2003 account.  

I can also send e-mail to the Internet from the moved Exchange 2010 mailbox, but cannot receive mail from an internet account back into Exchange 2010.  

Can anyone offer any insight?

Thanks in advance.
javornelasAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
For inbound email on Exchange 2010 you need to ensure that the Default Receive connector has anonymous , exchange users , exchange servers , legacy exchanges are enabled on it. If it does not, enable it and then restart the Transport store.
0
javornelasAuthor Commented:
Thank you very much for your reply.  Just so that I am certain of what I need to do, I need to make sure that the "Default Receive Connector" has these permissions set and not the "Client" receive connector?  I see that there are two connectors (Default and Client).  When you say restart the Transport store, is that a service?  Sorry, I'm not familiar enough with Exchange 2010 yet.  All my knowledge has been with Exchange 2003.

Thank you!
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
its default one for local use -> right click properties -> permission group .. info store is service.
Javornelas if you need further help just go to my EE profile there is my email send me email and will be with you remotely to solve all of your problem .. am ready to help.

good luck
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

javornelasAuthor Commented:
jordannet, I gave the "Default" receive connector on the Hub/Transport server the permissions as you mentioned and then restarted the HUB server entirely.  I am still having trouble when trying to send e-mails from Exchange 2003 users over to Exchange 2010 users.  The Exchange 2003 users can receive mail from the Exchange 2010 users just fine.

Thanks.
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
wait , who can not receive from other?? 2003 from 2010 or 2010 from 2003??? am confused a little about it , and what message or delivery report you've got
0
javornelasAuthor Commented:
I have an Exchange 2003 organization which I added Exchange 2010 servers to so that I can move all of the Exchange 2003 users to Exchange 2010.  I moved over two test accounts, and those two test accounts can e-mail users that are still in Exchange 2003.  However, the Exchange 2003 users cannot send e-mail back to the Exchange 2010 users.  
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
aha ,now i got it , because there is no routing between exchange 2010 and 2003 , what you need to do
 on exchange 2010 :
1- start -> run -> powershell
2- paste this command on powershell , but before past please modify the code to correct settings of your organization :
Interop RGC change it "your organization name"
exchange2010FQDN change it to YourExchange2010ServerName.domain.local like exch01.domain.local
do same for Exchange2003FQDN but for exchange 2003 server name.domain.local or .com whatever its
depends on yyour organization.

New-RoutingGroupConnector -Name "Interop RGC" -SourceTransportServers "exchange2010FQDN" -TargetTransportServers "Exchange2003FQDN" -Cost 10 -Bidirectional $true -PublicFolderReferralsEnabled $true

Open in new window

0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
forget to mention .. then :
On your exchange 2003 box restart "Simple Mail Transport Protocol" Service
 On your Exchange 2010 box restart "Mail Exchange Transport" Service

then try
0
javornelasAuthor Commented:
For the Exchange2010FQDN, I am entering my Hub/Transport server here correct?  

And for the Exchange2003FQDN, can I use any server?  Or should I use the Exchange 2003 mailbox server's FQDN?  

Do I need to leave the " " around the names or do I remove those?
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
yes on Hub transport server , the FQDN is Full Qualified Domain Name , suppose your exchange 2010 server name is exch1 and your local domain is domain.com or .local (i mean local not remote one) , so FQDN will be :
exch1.domain.local or exch1.domain.com
same thing for exchange 2003 , you should have " ".

do it and try then update me
0
javornelasAuthor Commented:
I tried the changes and it did not work.  I still cannot send e-mail from an Exchange 2003 mailbox to an Exchange 2010 mailbox.  

I ran the Exchange Management Shell script as you mentioned.  I didn't get any errors, so I thought It was fine.  I typed in the FQDN of the Exchange 2010 Hub/Transport Server.  And then I typed in the FQDN of the Exchange 2003 mailbox server.  

Just to let you know, I have 4 Exchange 2003 servers.  1 mailbox server, 1 front end server, 1 public folder server, and 1 server that acts as a bridgehead to the internet.

When you mentioned to restart the SMTP service on Exchange 2003, I didn't know which box, so I restarted it on all 4 servers.  

I restarted the Exchange Transport service on the Hub/Transport server.  

Still not working.

0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
please reboot exchange 2010 and try after reboot
0
javornelasAuthor Commented:
Which server should I reboot?  The Hub or the Mailbox server?  I have 3 Exchange 2010 servers.  1 Hub, 1 CAS, and 1 Mailbox.
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
hub one
0
javornelasAuthor Commented:
I'm sorry to say that this is still not working.  Still cannot e-mail from an Exchange 2003 mailbox to a Exchange 2010 mailbox.
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
ok try to apply routing group that i mentioned before on CAS server instead of Hub , if not sucessful try :

. Open ASDIedit on CAS by adding the snap-in to a MMC (should be included on your 2008 server where Exchange 2010 is installed)
2. Navigate to Configuration > Services > Microsoft Exchange > Exchange Organization > Administrative Groups > First Administrative Group > Servers
3. In the right pane, right click on the CN=Server Name of your Exchange 2003 Server, select properties
4. Navigate to the Security tab, hit advanced toward the bottom.
5. Check the checkbox that reads “include inheritable permissions” toward the bottom of the dialogue box.
0
javornelasAuthor Commented:
jordannet, just so that I am understanding you correctly, you would like me to run the Powershell script that you listed above but run it on the CAS instead of the Hub?  I thought that all routing groups should be on the Hub and not the CAS?
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
am sorry you are right i posted it by mistake never mind just do adsiedit steps
0
javornelasAuthor Commented:
OK, so I should run the ADSIedit steps from the Hub server?
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
yes...
0
javornelasAuthor Commented:
OK, I checked this with ADSIedit and the checkmark for "Include Inheritable permissions" is already checked.
0
Kamalasekar ParthasarathyMessaging SupportCommented:

Please post the NDR report of the error message when you send mail from 2003 to 2010.

It will help us troble shoot further.

Also, please check the external mail flow is working or not in exchange 2010 server
0
Kamalasekar ParthasarathyMessaging SupportCommented:
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
javornelasAuthor Commented:
sekar_raj32 - I am not getting an NDR when trying to send from 2003 to 2010 accounts.  It just doesn't arrive and no NDR.

I am able to send from an Exchange 2010 account to an Exchange 2003 account as well as to an internet mail account (Yahoo mail).  I cannot send back from Yahoo mail to the Exchange 2010 account though.  

So in short, the only way the Exchange 2010 account can receive e-mail is from another Exchange 2010 account.
0
Kamalasekar ParthasarathyMessaging SupportCommented:

Did you check the receive connector in Exchange 2010 and the permission should be anonymous.. also enable everything under permission tab.

Can you check your authentication mechanism under receive connector: Make sure it should set exchange server authentication and windows authentication.

Also, restart your hub transport server and will wait for atleast 2 hrs.






 
0
Kamalasekar ParthasarathyMessaging SupportCommented:
In the mean time i request to check the below link

http://www.petri.co.il/forums/showthread.php?p=250229

_______________________________________________

Please check the telnet with port 25 between the exchange 2003 and 2010.
From Exchange 2010 queue, are able to find the emails getting stuck up. if any then you can find the error code message and post the same
0
javornelasAuthor Commented:
sekar_raj32 - thank you again for your tips.  I tried checking the permissions for the receive connector and found that the Anonymous was already checked.  I went ahead and enabled everything under the Permission tab.

I also checked the authentication mechanism under the receive connector and I didn't see that Exchange Server Authentication was checked, so I checked it.  I then restarted the Hub/Transport server.  Do I need to wait 2 hours before retrying?

I will move onto your next tip shortly.

Thanks!
0
javornelasAuthor Commented:
I misspoke earlier.  12 hours after I sent the original e-mail from my Exchange 2003 account to an Exchange 2010 account, I finally got a "message delayed" error:

Reporting-MTA: dns;TEAM-EXCHANGE1.hc.msu.edu

Final-Recipient: rfc822;Third.Test@hc.msu.edu
Action: delayed
Status: 4.4.7
Will-Retry-Until: Wed, 28 Dec 2011 15:08:17 -0500
X-Display-Name: Third Test

The above account Third.Test@hc.msu.edu has been moved over to Exchange 2010 and I was trying to send e-mail to it from an Exchange 2003 account.  

Does this help?
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
0
Kamalasekar ParthasarathyMessaging SupportCommented:
Yes please wait.. in the mean time, can you please confirm, do you have replication issue on the AD site.

Also, make sure you should able to find the DC/GC information under Hub server properties.

Can you confirm are you able to do telnet with port 25 between these two server(Exch 2003 to Exch 2010 hub server)

Also, let me know if you have any firewall /Email gateway servers are in your exchange organization.

Example like edge server or Message labs like that.
0
Kamalasekar ParthasarathyMessaging SupportCommented:
0
javornelasAuthor Commented:
sekar_rag32 - thank you for your replies.  I have let the changes take effect from hours earlier and tried to see if I could e-mail from the Exchange 2003 mailboxes to the Exchange 2010 mailboxes and still was not successful.  I also still cannot e-mail from the Internet to the Exchange 2010 accounts.  

I tried to use Telnet from the mailbox server on Exchange 2003 to the HUB server on Exchange 2010 and it is not working.  I then tried to send telnet from the HUB server to Exchange 2003 and that also isn't working.  I receive "Could not open connection to the host" error messages.

We do have a firewall in the organization, but the Exchange 2003 and Exchange 2010 servers are all behind the firewall in the same subnet as well.  We do not have an Edge server in place at this time.  We do have a Barracuda Spam Firewall which sits in front of the Exchange 2003 server right now, and what I was hoping to do is migrate all of the mailboxes to Exchange 2010 and then use the Barracuda in front of the Exchange 2010 server.
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
am just trying to figure it out I figured it out. Under the properties for the SMTP Server on Exchange 2003 and then Under the Access tab and Authentication, I needed to have Integrated Windows Authentication checked.
restart SMTP service on exchange 2003 and try to send
0
javornelasAuthor Commented:
jordannet - I looked at the SMTP Virtual Server on Exchange 2003 and found that integrated Windows Authentication is already checked.

Just to remind everyone, the problem I'm having now is that I have moved 2 mailboxes from Exchange 2003 to Exchange 2010.  Once I moved those 2 mailboxes, I can still send e-mail to the rest of the Exchange 2003 mailboxes and to the internet, but those 2 mailboxes cannot receive e-mail from Exchange 2003 accounts and they also cannot receive e-mail from the internet.
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
ok try to export these mailboxes and delete them then recreate them again and see what will happened , or just to try create new mailbox on 2007 and send to from 2003 any email , if its received well then you need to export mailboxes and recreate them
0
javornelasAuthor Commented:
jordannet - I also created a new Exchange 2010 account (which I didn't move from Exchange 2003) and I'm having the same problems with it.  It cannot receive e-mail from Exchange 2003 accounts nor from the Internet.
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
please stop windows firewall on exchange 2007 and try
0
javornelasAuthor Commented:
Which Exchange 2010 server should I stop the Windows Firewall on?  The CAS, Hub, or Mailbox server?
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
2010 hub
0
javornelasAuthor Commented:
jordannet - I have stopped the Windows Firewall service on the 2010 hub server and then tried to send e-mail to the 2 Exchange 2010 mailboxes from an Exchange 2003 mailbox.  It is still not being received.
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
ok ,on hub transport server go  to EMC -> server configuration -> Hub Transport -> double click on Default  ( on receive connector) then tab permission group , tick :
anonymous users.
exchange users.
exchange servers.
legacy exchange servers.

do the same for client connector and restart exchange services
0
javornelasAuthor Commented:
jordannet - I checked the receive connectors and those permission groups are already selected.  I believe I did this yesterday when trying to figure this out.  I rebooted the Hub server after making this change as well.  Still no luck.

0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
create new SMTP connector , go to organization Configuration -> hub transport -> right click then new smtp connector -> type name and select custom -> next -> on address space -> click add then on addresses enter * -> next -> on network settings select route mail through this smart host -> add -> add IP address of the exchange 2003 Server (the server have application) IP -> set authentication to None -> next -> new
restart exchange 2010 services then try again...am doing my bests to serve you , however also please do the following clear all events in application section in event viewer then try to send , i want to know if there is any event raise it will be helpful
0
javornelasAuthor Commented:
jordannet - do I need to delete the existing SMTP connector?

I appreciate ALL of your help!  Thank you very much!  Did you want me to clear out the events in the Application Logs on the 2003 server (if so, which 2003 server?) or 2010 Hub Transport server?
0
Kamalasekar ParthasarathyMessaging SupportCommented:
We need to find this solution..

Please run the below command and post the message

Get-ReceiveConnector -identity * | FL > c:\Rec.txt

Attach the message.. will check the receive connector configuration details.

Can you please confirm one thing.. How many Hub servers do you have in your organization. Please make sure that you have to enable the settings for all your hub server under receive connector properties
0
Kamalasekar ParthasarathyMessaging SupportCommented:
As I said.. the port 25 should be opened between the exchange servers to route the emails.

Can you please check your Default Receive connector Properties > Network -> Just check the port 25 is listed or not in TCP/Ip

Please confirm the same.

0
Kamalasekar ParthasarathyMessaging SupportCommented:

Also, Just send one email from 2003 to 2010.. and check your SMTP queues in Exchange 2003..

Also, i request to check in your exchange 2003, did you configured any smart host to route the emails, please check as well.

Also i found with same kind of issue from the internet, can you please check the below settings in ADSIEDIT

By re-establishing inheritance to the 2003 server object, mail flow was instantly restored between the servers.

To re-establish inheritance:

1. Open ASDIedit by adding the snap-in to a MMC (should be included on your 2008 server where Exchange 2010 is installed)

2. Navigate to Configuration > Services > Microsoft Exchange > Exchange Organization > Administrative Groups > First Administrative Group > Servers

3. In the right pane, right click on the CN=Server Name of your Exchange 2003 Server, select properties

4. Navigate to the Security tab, hit advanced toward the bottom.

5. Check the checkbox that reads “include inheritable permissions” toward the bottom of the dialogue box.

Thanks
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
No don't delete existing , just create new one and test
0
javornelasAuthor Commented:
sekar_raj32 - we have 1 HUB server, 1 CAS, and 1 Mailbox server in Exchange 2010 at this time.  I checked the Default Receive Connector Properties > Network and Port 25 is listed.

Attached is the rec.txt file.
 Rec.txt
0
javornelasAuthor Commented:
sekar_raj32 - I sent another e-mail from an Exchange 2003 account to the 2 Exchange 2010 accounts.  

I am posting a picture of what the queue looks like on the Exchange 2003 side.

I then checked to see if there are any smart hosts to route e-mails are there are not (I checked the Internet Mail SMTP connector) Exchange 2003 queue after sending messages to Exchange 2010
0
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
oops jav , your problem not been solved yet?? OMG ..
see this possible solution :

http://geekswithblogs.net/cajunmcse/archive/2010/12/22/another-exchange-2003-to-exchange-2010-mail-flow-issue.aspx

also  see this article to review your configuration :

http://www.petenetlive.com/KB/Article/0000234.htm

0
Kamalasekar ParthasarathyMessaging SupportCommented:

From the queue did you checked the Routing group connector in Exchange 2003.. it seems there is a promlem in routing the emails to 2010.

Please check your routing group connector.   and check the port as well.

Just have to give small info,  If possible can you do reboot your exchange 2003 server and will check it.

Might be restart will work.
0
javornelasAuthor Commented:
sekar_rag32 - I haven't rebooted the Exchange 2003 server since adding in the Exchange 2010 servers and the routing group connector was created.  Thank you for the tip, I will do that after hours tonight.
0
Kamalasekar ParthasarathyMessaging SupportCommented:

Hi...

Let us know the status. Still your facing the issue, please download winroute and test it in exchange server 2003..
0
javornelasAuthor Commented:
The problem with this issue was that the automatically created Routing Group Connector was not working.  I deleted it and recreated it and now mail flow is fully working between Exchange 2003 --> Exchange 2010 and Exchange 2010 --> Exchange 2003.  

Thank you to ALL that posted!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.