Cisco Switch Replacement Question - 2960G

I am replacing a pair of Cisco 2960G 8 port switches with a pair of Cisco 2960-S series SI 24 port gig switches.  Below is the run of the 8 port 2960.  Its used for the ISCSI backbone for an EMC Celerra SAN and 3 HP VMWare hosts.  I program the new 24 port exactly the same but it will not work like the 8 port 2960.

here's the running config of the 8 port:
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface Port-channel1
 switchport access vlan 100
!
interface Port-channel2
 switchport access vlan 100
!
interface GigabitEthernet0/1
 switchport mode trunk
!
interface GigabitEthernet0/2
 switchport mode trunk
!
interface GigabitEthernet0/3
 switchport mode trunk
!
interface GigabitEthernet0/4
 switchport mode trunk
!
interface GigabitEthernet0/5
 switchport mode trunk
!
interface GigabitEthernet0/6
 switchport mode trunk
!
interface GigabitEthernet0/7
 switchport access vlan 100
 channel-group 1 mode active
!
interface GigabitEthernet0/8
 switchport access vlan 100
 channel-group 1 mode active
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Vlan100
 no ip address
 no ip route-cache
!
interface Vlan101
 no ip address
 no ip route-cache
!
ip http server
ip http secure-server
!
control-plane
!
!
line con 0
line vty 0 4
 password 7 15530301572E6A
 login
line vty 5 15
 password 7 15530301572E6A
 login
!
end

Very basic.  The 24 port matches exactly.
From this config I assume:

Since all ports are trunked and the port group for ports 7-8 are in a VLAN, then any other port should be able to communicate with devices on port group 1 (7-8) as long as they are on the same ip network.  However, when plugged into the 8 port and my laptop on the same network as the EMC's controller, I cannot ping that device yet the switch works.

If I replace the 8 port with the 24 port then the EMC is unaccessable.  On the 24 port, i'm using port 23 and 24 as the port group and making them members of VLAN100.  

I am missing something and cannot see what it is.

Can someone open my eyes?

Thanks for any input.
RFloyd30Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lruiz52Commented:
show the config of the 24 port.
0
Garry GlendownConsulting and Network/Security SpecialistCommented:
Plugging in a notebook, most likely the port isn't tagged ... therefore, you'd end up in the default VLAN 1, which in turn can't communicate with devices on VLAN 100 ... (unless you have some inter-VLAN-routing somewhere in your infrastructure)
0
RFloyd30Author Commented:
Thanks for the input.

Below is the 24 port config.

If each port is in trunking mode, then why should I have to tag anything?  Is that not the purpose of trunking?  A trunk in the Cisco IOS world see's all VLANs.  When I do a uplink between switches, they are programmed as trunks so that all VLANs pass between switches, especially when a layer 3 device is available to route between the networks.

These switches are totally standalone in this environment meaning that they are not connected to the LAN at all.  The only devices that plug into them other than the EMC SAN are the NICs on the VMWare hosts.

Thanks again for the input.




spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
!
interface Port-channel1
 switchport access vlan 100
!
interface Port-channel2
 switchport access vlan 101
!
interface FastEthernet0
 no ip address
 shutdown
!
interface GigabitEthernet0/1
 switchport mode trunk
!
interface GigabitEthernet0/2
 switchport mode trunk
!
interface GigabitEthernet0/3
 switchport mode trunk
!
interface GigabitEthernet0/4
 switchport mode trunk
!
interface GigabitEthernet0/5
 switchport mode trunk
!
interface GigabitEthernet0/6
 switchport mode trunk
!
interface GigabitEthernet0/7
 switchport mode trunk
!
interface GigabitEthernet0/8
 switchport mode trunk
!
interface GigabitEthernet0/9
 switchport mode trunk
!
interface GigabitEthernet0/10
 switchport mode trunk
!
interface GigabitEthernet0/11
 switchport mode trunk
!
interface GigabitEthernet0/12
 switchport mode trunk
!
interface GigabitEthernet0/13
 switchport mode trunk
!
interface GigabitEthernet0/14
 switchport mode trunk
!
interface GigabitEthernet0/15
 switchport mode trunk
!
interface GigabitEthernet0/16
 switchport mode trunk
!
interface GigabitEthernet0/17
 switchport mode trunk
!
interface GigabitEthernet0/18
 switchport mode trunk
!
interface GigabitEthernet0/19
 switchport mode trunk
!
interface GigabitEthernet0/20
 switchport mode trunk
!
interface GigabitEthernet0/21
 switchport access vlan 101
 channel-group 2 mode active
!
interface GigabitEthernet0/22
 switchport access vlan 101
 channel-group 2 mode active
!
interface GigabitEthernet0/23
 switchport access vlan 100
 channel-group 1 mode active
!
interface GigabitEthernet0/24
 switchport access vlan 100
 channel-group 1 mode active
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface Vlan1
 no ip address
!
interface Vlan100
 no ip address
 no ip route-cache
!
interface Vlan101
 no ip address
 no ip route-cache
!
ip http server
ip http secure-server
!
line con 0
line vty 0 4
 password
 login
line vty 5 15
 password
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

RFloyd30Author Commented:
another quick point... the reason for doing the switch swap is for more ports.  the EMC celerra has a blade enclosure that has 2 blades that are fault tolerant for each other.  They are programmed exactly the same and if one should fail, then the other will take over.  Currently only one blade is physically plugged in thus the need for more ports.  The networks are 10.10.1.0 and 10.11.1.0 both class B.  All this was done by previous onsite network admin.  

Thanks
0
Garry GlendownConsulting and Network/Security SpecialistCommented:
A trunked port will allow any known VLAN in, and forward data for all known VLANs out. BUT, anything apart from the default VLAN needs to be TAGGED, otherwise, well, it's going to the default VLAN ... your other servers (I assume they run some VM?) most likely tag their link towards the storage, so of course they will work. Your notebook isn't tagged, so it can't see your storage ...

Speaking of known VLANs ... that's one thing I don't see in your config ... old Cisco switches used a separate VLAN database, newer IOS versions use the regular config to configure the VLANs ... make sure you configure any and all VLANs you want to use, in this case:

vlan 100
name SOMENAME

vlan 101
name SOMEOTHERNAME

Open in new window


(if "show vlan" doesn't list VLAN 100, forwarding for that VLAN won't happen ...)

For tests, configure an IP on the VLAN interface from the appropriate IP range and see whether you can reach the storage from the switch ... and the switch from a server.
0
Garry GlendownConsulting and Network/Security SpecialistCommented:
P.S. - if you want to try with your notebook, just put the port you connect it to in access mode in VLAN 100...
0
RFloyd30Author Commented:
Thanks - I will give it a try and see what is happening.  The odd thing is why does the 2960 8port work when in the production environment work and when the 24 port replaces it, it does not work?  The programming to me looks the same.  I can see the vlans when doing a sh vlan.  I did go into "VLAN Database" and created them there.  I'm used to VTP domains...

Is ISCSI different than normal IP?  I will look at the VMWare config too and check out its programming.

Appreciate the input for sure!
0
Garry GlendownConsulting and Network/Security SpecialistCommented:
Most likely you have the virtual interfaces configured in VMWare to use VLAN 100 ...
Also, the 2960S is a newer switch than the 2960G ... you may notice that when doing "vlan database" it will complain about the command be out-of-date, and regular config mode used to configure vlans ... commands like "vlan" etc. will not be listed anymore, though they might still accept input - but probably will ignore everything you do there ...
0
lrmooreCommented:
Make sure that you actually create Vlan 100 on the switch. It does not get created automatically.
Issue the following command:
switch(config)#vlan 100
switch(config-vlan)#end
switch#
0
RFloyd30Author Commented:
I did notice the vlan database command was very limited...  I will remove the vlans created and then create them new and test.  

Thanks for al the input and will report back.

0
RFloyd30Author Commented:
Just an update - no luck in getting the new switch to work.

When looking at the eight port unit in production, there are no ports associated with VLAN100 except the port group.  The reason is that all ports are trunked.  If i take one port out of the trunk and put into VLAN100, then I can pink the ISCSI NICs in the vmware hosts plus the EMC control blade.  If i give VLAN100 an ip address, then I can do so via the switch.  

No matter how i program the new 24 port switch, it does not work.  Even if i put the ISCSI ports in VLAN100 with its port group, still no communicated between the servers and the EMC SAN.

There must be a global Cisco command or state that the 8 port switch is performing and it does not show up in the sh run command?  Why is this so?  I'm stumped and consider myself knoweledgeable about layer2 and 3 switching.

Thanks again for any input...
0
RFloyd30Author Commented:
sorry - thought this was closed.

Problem solved - with ISCSI, packet size across all nodes must be equal.  

In this environment, the ISCSI packet size was set to 9000.  After reading, this is normal.

Thus enabling large packets and setting to 9000 on the switch solved the issue.

Thanks for all the input.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
RFloyd30Author Commented:
solved the issue
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.