SharePoint 2010 Exception User Cannot be found error

We recently changed from claims to classic on our site collection.  Everything worked except that some lists that were created in claims now show an error when you try to create a workflow.  It says the user is not found.  I am trying to figure out a workaround for this issue and thought maybe someone might have an idea on this.

Here is the exception from the ULS
Microsoft.SharePoint.SPException: User cannot be found.  
 at Microsoft.SharePoint.SPUserCollection.get_Item(String loginName)    
 at Microsoft.SharePoint.Workflow.SPWorkflowNoCodeSupport.LoadWorkflowBytesElevated(SPFile file, Int32 fileVer, Int32& userid, DateTime& lastModified)    
 at Microsoft.SharePoint.Workflow.SPWorkflowManager.AddDeclSiteTemplates(SPWeb web, String visibility, SPWorkflowTemplateCollection wftemplates, SPListTemplateType templateType)    
 at Microsoft.SharePoint.Workflow.SPWorkflowManager.<>c__DisplayClass4.<RegisterNoCodeTemplates>b__0()    
 at Microsoft.SharePoint.SPSecurity.<>c__DisplayClass4.<RunWithElevatedPrivileges>b__2()    
 at Microsoft.SharePoint.Utilities.SecurityContext.RunAsProcess(CodeToRunElevated secureCode)    
 at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(WaitCallback secureCode, Object param)    
 at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(CodeToRunElevated secureCode)    
 at Microsoft.SharePoint.Workflow.SPWorkflowManager.RegisterNoCodeTemplates(SPWorkflowTemplateCollection wftemplates, SPWeb web)    
 at Microsoft.SharePoint.SPWeb.get_WorkflowTemplates()    
 at Microsoft.SharePoint.Workflow.SPWorkflowAssociationCollection.UpdateAssociationsToLatestVersion()    
 at Microsoft.SharePoint.ApplicationPages.WorkflowPage.ConstructStartArray()    
 at Microsoft.SharePoint.ApplicationPages.WorkflowPage.OnLoad(EventArgs e)    
 at System.Web.UI.Control.LoadRecursive()    
 at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
swtjen1Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

swtjen1Author Commented:
SOLUTION:  As strange as it sounds you have to open up the site collection and republish all the global workflows.  Once we did this the workflows and lists opened up without error.

Here is a link that explains:  http://www.estruyf.be/blog/user-cannot-be-found-when-opening-listlibrary-settings/
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.