APP Fabric constantly failing

Guys,

i am having with Appfabric server that started to crash.

in the logs i see:

Application: DistributedCacheService.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.Runtime.CallbackException
Stack:
   at System.Net.Security.NegoState.WriteCallback(System.IAsyncResult)
   at System.Net.LazyAsyncResult.Complete(IntPtr)
   at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
   at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)
   at System.Net.ContextAwareResult.Complete(IntPtr)
   at System.Net.Sockets.BaseOverlappedAsyncResult.CompletionPortCallback(UInt32, UInt32, System.Threading.NativeOverlapped*)
   at System.Threading._IOCompletionCallback.PerformIOCompletionCallback(UInt32, UInt32, System.Threading.NativeOverlapped*)

i tried to upgrade the appfabric to 1.1 (it was 1.0) but it is still the same.

i saw that other people had the same but iwas not able to find a solution:
http://social.msdn.microsoft.com/Forums/en-CA/velocity/thread/4af22605-cde9-4246-99c1-cacb41421917 
http://stackoverflow.com/questions/8474804/appfabric-1-1-caching-crashing-windows-service

can you help?
AsteaDevAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David Johnson, CD, MVPOwnerCommented:
i tried to upgrade the appfabric to 1.1 (it was 1.0) but it is still the same.

Did you update the references in your project.. the version 1.0's are in the GAC and have to be overwritten.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AsteaDevAuthor Commented:
the system worked before and stopped working and after few second after i do start-cachecluster the service is down.

the .Net App Server are installed.

what do you mena IIS zones?

0
AsteaDevAuthor Commented:
i am not sure about the GAC issue since I dont have yet a problem with my code & project.

the service crash few seconds after i start it, even if i dont call the APPFABRIC.

any other idea?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Development

From novice to tech pro — start learning today.