SBS 2011 WSUS clients Missing

Hi guys,

I have migrated SBS 2011 from 2003.After migration everything working fine apart form WSUS.
I got around 40 PC's on my network but none of them showing in WSUS console apart from SBS server!

Any suggestion?

Thank you
Vijay
VijaytyagiAsked:
Who is Participating?
 
DonNetwork AdministratorCommented:
Run on the clients: (in a .bat)


%Windir%\system32\net.exe stop bits
%Windir%\system32\net.exe stop wuauserv
%Windir%\system32\net.exe stop cryptsvc
reg delete HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v SusClientId /f
reg delete "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update" /v LastWaitTimeout /f
reg delete "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update" /v DetectionStartTime /f
reg delete "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update" /v NextDetectionTime /f
del %WINDIR%\WindowsUpdate.log /S /Q
rd /s /q %windir%\softwareDistribution
%Windir%\system32\net.exe start cryptsvc
%Windir%\system32\net.exe start bits
%Windir%\system32\net.exe start wuauserv

wuauclt /resetauthorization /detectnow

wuauclt /reportnow


The bold  are the key items
0
 
DonNetwork AdministratorCommented:
Have you modified the GPO to point to the new server ??? (set intranet statistics server...)


http://technet.microsoft.com/en-us/library/cc708567(WS.10).aspx


To point the client computer to your WSUS server
In Group Policy Object Editor, expand Computer Configuration, expand Administrative Templates, expand Windows Components, and then click Windows Update.

In the details pane, double-click Specify intranet Microsoft update service location.

Click Enabled, and type the HTTP URL of the same WSUS server in the Set the intranet update service for detecting updates box and in the Set the intranet statistics server box. For example, type http://servername in both boxes.

Click OK.
0
 
AJS2011NZCommented:
As part of the migration, you are required to delete the old SBS GP objects, including the WSUS GP's pointing to the old server? Was this completed? Specifically, the following GP objects need to be removed.

Small Business Server Update services Client Computer Policy
Small Business Server Update Services Common Settings Policy
Small Business Server Update Services Server Computer Policy

0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
VijaytyagiAuthor Commented:
Guys,

Thanks for your advice.

I have done all you advised but still not success.

I just run clientDiag.exe and got below output.

WSUS Client Diagnostics Tool

Checking Machine State
        Checking for admin rights to run tool . . . . . . . . . PASS
        Automatic Updates Service is running. . . . . . . . . . PASS
        Background Intelligent Transfer Service is running. . . PASS
        Wuaueng.dll version 7.4.7600.226. . . . . . . . . . . . PASS
                This version is WSUS 2.0

Checking AU Settings
        AU Option is 4: Scheduled Install . . . . . . . . . . . PASS
                Option is from Policy settings

Checking Proxy Configuration
        Checking for winhttp local machine Proxy settings . . . PASS
                Winhttp local machine access type
                        <Direct Connection>
                Winhttp local machine Proxy. . . . . . . . . .  NONE
                Winhttp local machine ProxyBypass. . . . . . .  NONE
        Checking User IE Proxy settings . . . . . . . . . . . . PASS
                User IE Proxy. . . . . . . . . . . . . . . . .  NONE
                User IE ProxyByPass. . . . . . . . . . . . . .  NONE
                User IE AutoConfig URL Proxy . . . . . . . . .  NONE
                User IE AutoDetect
                AutoDetect not in use

Checking Connection to WSUS/SUS Server
                WUServer = http://ServerA
                WUStatusServer = http://ServerA
        UseWuServer is enabled. . . . . . . . . . . . . . . . . PASS
                Client is pointed to SUS 1.0 Server
        Connection to server. . . . . . . . . . . . . . . . . . PASS
        SelfUpdate folder is present. . . . . . . . . . . . . . PASS



 Any Idea?

Thank you
0
 
VijaytyagiAuthor Commented:
Dstewartjr, you are a legend!

Thank you very much for your help and Wish you a Very Happy New Year 2012.
Apart from running batch script I added port as well in my GP.

I can see systems getting update as well showing in WSUS consol.

To AJS2011NZ, Yes I have update the GP after migration.Thank you for your help and time!

Cheers
Vijay
0
 
DonNetwork AdministratorCommented:
Yes, the port was most likely your issue all along...since I believe SBS 2011 has sharepoint by default so WSUS is forced to use port 8530.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.