ACT! can't find database supplemental files

I've got multiple workstations that access an ACT database. The host is a Win7, one client is xp, and another is Win7. The xp and the host 7 can access the database just fine. However, one Win7 throws an error saying that it can't find the database supplemental files folder in the specified location. Funny, since the xp machine is doing just fine.

I've searched through all the kb articles with no success. I've verified the permissions, the share, changed the PAD file to look for the IP address, then back to the machine name, I've changed the datastore to the IP address. Nothing is working. Help please!
fieldb1Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mike LazarusAct! Evangelist - CRM ConsultantCommented:
Have you tried the other items here:
http://kb.sagesoftwareonline.com/app/answers/detail/a_id/19876

Or an older one here:
http://kb.sagesoftwareonline.com/app/answers/detail/a_id/14101

What folder (on local machine) is the database?
If under "Users", I'd Backup, then Restore | Restore_As ... and move it to c:\actdata
The preferences in "Users" can do some odd things

If still a problem, what version/build of ACT! - from help about?
Check all to make sure all same.
0
fieldb1Author Commented:
Thanks for the response.

I've tried the fixes in the first kb. I'm hesitant to delete the PAD, since all is well on the other machine.

I have a PAD file located on a network share that points to the database on the Win7 host machine. When I restore the database to c:\actdata, I'll need to alter the path in the network share PAD, correct?

I checked the versions and builds. I needed an update, but after I still get the same error.
0
Mike LazarusAct! Evangelist - CRM ConsultantCommented:
It will create a new Pad ... deleting the pad isn't an issue. It's just a pointer to the database (you can open it with Notepad)

What version/build?
0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

fieldb1Author Commented:
ACT! by Sage 2009 (11.0) Version 11.1.183.0, Hotfix 1
All machines have the same version and build.

I created c:\actdata and restored the database. Then, I copied the pad to the network share so that the clients would be able to find the database. Still the exact same error.

Also, I did delete the original pad and open the adf file to create the new pad. The error persists.

Frustrating, being that the xp machine is accessing the database just fine.
0
Mike LazarusAct! Evangelist - CRM ConsultantCommented:
Can you first update to Hotfix 4 (all machines) as per:
http://kb.sagesoftwareonline.com/app/answers/detail/a_id/25657

Then, I assume you're running a workgroup and not a domain?
If so, can you add each user's Windows username and password to the machine hosting the database and give them access in the security to the shared folder
0
fieldb1Author Commented:
I'm in a domain.
0
fieldb1Author Commented:
Hotfix applied. Still throwing the error on the Windows7 machine.
0
Mike LazarusAct! Evangelist - CRM ConsultantCommented:
Ok... can you try a different network login on the failing machine?
Want to see if it's related to the user

I'd also do the update
0
Mike LazarusAct! Evangelist - CRM ConsultantCommented:
If the security permissions on the folder is "everyone" can you directly add the user from the failing machine?
0
fieldb1Author Commented:
Update is already in place.

The user is already granted full permissions, along with his group (for good measure).

I will use a different login at noon.

Thanks.
0
fieldb1Author Commented:
OK, when I log on with my credentials I am able to open the database.

This is strange, as I have manually added the user and group in question to every folder with full permissions. Any ideas?
0
Mike LazarusAct! Evangelist - CRM ConsultantCommented:
To which folder have you given the other user permissions?
0
Mike LazarusAct! Evangelist - CRM ConsultantCommented:
Normally, it should just be to the c:\actdata folder (as above) and subfolders
0
fieldb1Author Commented:
That's correct.
0
Mike LazarusAct! Evangelist - CRM ConsultantCommented:
Well, it obviously is something in the permissions ... have you given "Full Control"
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
ACT

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.