Properly connecting an unmanaged switch to a Cisco 2960

I'm having DHCP issues when connecting an unmanaged switch to my Cisco 2960 switches.  I have the port it is connected to set to access VLAN1 which is the native vlan for all traffic.  Some computers are able to connect and receive DHCP perfectly.  A static IP printer is also running off the unmanaged switch and is able to be accessed from all parts of the network.  I have statically assigned IP's to those computers that do not receive an IP and I'm able to ping any PCs connected to the unmanaged and I'm not able to ping internet domains or the file servers upstream from the unmanaged switch.  I'm guessing that multicasting is not travelling back up to the 2960 from the unmanaged switch.  I need a little help in understanding how to set up the 2960 to communicate properly with the unmanaged switch.  

The unmanaged switch is an SMC 10/100.  I need to get this running temporarily until i'm able to run homeruns back to the computer room into a newly acquired space.  
danny8280Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lrmooreCommented:
You should be able to simply set the 2960 port to switch mode access and be done with it.
That will set to vlan 1 as native, untagged.
You might have a duplex mismatch.
Check the duplex on the 2960 that is negotiated. The port needs to be set to auto and not 100/full.
0
lruiz52Commented:
on the switch port connected to the smc do

switchport mode access
switchport access vlan 1 (just to make sure)
switchport no nonegotiate (is should run at the speed and duples of the smc)
switchport no shut
0
danny8280Author Commented:
Speed and duplex are both auto, as are all ports.  This is the port setup below.  1 machine will take DHCP on that unmanaged switch and anything plugged in after will not.  I can set IP on machines to static but they will not ping past the unmanaged switch, only to things connected to the unmanaged switch.  I can't ping from the Cisco down to those things i set to static, only to the one computer that received the DHCP.  It almost seems like the Cisco doesn't know the route to anything on that port except the first one assigned.  

GigabitEthernet1/0/7 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 40f4.ec70.7b07 (bia 40f4.ec70.7b07)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, media type is 10/100/1000BaseTX
  Media-type configured as  connector
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 18:55:01, output 00:00:00, output hang never
  Last clearing of "show interface" counters 11w2d
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 1808
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 92000 bits/sec, 62 packets/sec
  5 minute output rate 72000 bits/sec, 60 packets/sec
     7434661 packets input, 2663625336 bytes, 0 no buffer
     Received 77286 broadcasts (10824 multicasts)
     0 runts, 0 giants, 0 throttles
     2 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 10824 multicast, 0 pause input
     0 input packets with dribble condition detected
     10928682 packets output, 8948189620 bytes, 0 underruns
     0 output errors, 23 collisions, 3 interface resets
     0 babbles, 127 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

danny8280Author Commented:
OK so after looking through configurations of the switch ports, which the previous network admin set up, I find that each port has "port-security maximum 2" set on it.  Changed to 10 and now devices work.  Previous admin had limited devices per port to 2 devices.  
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
danny8280Author Commented:
Solved own problem with help from others.
0
danny8280Author Commented:
Solved.
0
lrmooreCommented:
Ahso.. thanks for the update and glad you got it worked out.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.