Hosted remoteapp problem with credentials when using .RDP

I am trying to setup a hosting evironment for my customers so they can access applications via web (Microsoft RDweb). The solution is running on a new installation of 2008R2
 I have 3 companies who will access this solution.
The solution is working, they can access the webpage and login and execute the application via web.
I have generated a .RDP file via Remoteapp manager and published it to the users desktop so they can execute it. when the user does this, they are prompted for credentials. In the old solution they where only prompted ones and the credentials was stored, so the next day they could just doubleclick and the the app was running with no further credentials needed to be entered.
The customer will not accept that they need to login everytime they open a remoteapp via the generated .RDP (especially when the old solution at the old provider was working, probably on a 2003 server)
It seems like after Server 2008 it is no longer possible to save user credentials in the .RDP. the username seems to be stored but not password, so the user is prompted for password everytime they double click the .RDP.

How do I fix the problem with my customers wont accept to login everytime they open the .RDP, and the fact that the credentials could not be saved.
The server (2008r2) is running in a domain so the user has to logon with Domain\credentials. So I assume that I cannot make the SSO solution, since the user will come with there own credentials e.g. Contoso\username.
Any workarounds?
Have I misunderstood the SSO so I can some how get this to work eventhough I dont know the username and password of the customers own/home AD?


MrbonnAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JacobfwCommented:
0
Don ThomsonCommented:
If you go to the Server 2008 and administratuive tools - terminal services - configuration - right mouse click on the RDP-Tcp  connection and goto properties  - under log on Setting you can uncheck the Always prompt for  a password.
0
MrbonnAuthor Commented:
@DTHConsulting.
I dont have Terminal - Services - configuration.
I found under Administrative tools Remote Desktop Session Host server - Connection - Rightclick on the RDP-TCP - Properties.Here I found the Log on settings, but the Always prombt for password was allreaddy unchecked so it was not the exact solution.
Under the General tab I found that the certificate was the default certificate not the one purchased. I then chose the bought license, applyed this settings, and sudenly everythings seems to be working with no extra prompt for password.
So the issude was due to wrong certificate on the RDP part. I changed this to the same certificate for both IIS and RDP.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MrbonnAuthor Commented:
The solution was due to certificate issue.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.