SharePoint Hostnamed sitecollection

Hi,
I have a SharePoint standalone setup in my test server. created hostnamed sitecollection under 80 webapp using powershell script. created the sitecollection with no issue. i can access the site from outside the network. but search in the hostnamed sitecollection is not working.
Its not showing error.but what u search doesnt yield any kind of result.
Pinemail11Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Justin SmithSr. System EngineerCommented:
Did you add the host named URL to your Search content sources?  Can you access the site from the search server (if not you may need to disable loopback)?
Justin SmithSr. System EngineerCommented:
Also, I guess I should have asked, has a crawl successfully completed?
Justin SmithSr. System EngineerCommented:
You do NOT have to specifiy the host named URL in your content source, as long as the root URL of the web app is listed.  Sorry for the confusion, just ignore my first comment.
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

Pinemail11Author Commented:
Guys,

Thanks for the reply.

I am using SharePoint Foundation. so i dont think there is a chance to control the search service application. Without search service application, u cannot able to add url in content source.
Justin SmithSr. System EngineerCommented:
Sorry, I assumed you had full Server.

Honestly I've yet to do a host named site on a Foundation farm.  My question to you remains, has the index completed?  Or, has it been 24 hours since you deployed the site?  Are there any errors in the App Event Log on the server?
Pinemail11Author Commented:
This is what the error i am getting in event log

sts4://www.xxx:6442/contentdbid={2cacb0ef-e9b2-4016-8e96-312d7ebf4c12} cannot be crawled.

Context: Application 'Search_index_file_on_the_search_server', Catalog 'Search'

Details:
      The URL of the item could not be resolved. The repository might be unavailable, or the crawler proxy settings are not configured. To configure the crawler proxy settings, use Search Administration page.   (0x80041221)
Justin SmithSr. System EngineerCommented:
Is that the URL of the web app you created the host site under?  Does the web app you created the host site under have a root site?  

You may need to disable loopback on your server:

2.Click Start, click Run, type regedit, and then click OK.
3.In Registry Editor, locate and then click the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

4.Right-click Lsa, point to New, and then click DWORD Value.
5.Type DisableLoopbackCheck, and then press ENTER.
6.Right-click DisableLoopbackCheck, and then click Modify.
7.In the Value data box, type 1, and then click OK.
8.Quit Registry Editor, and then restart your computer

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Pinemail11Author Commented:
no luck.

Could you please explain me how i need to proceed from the frst step onwards?

I have followed the process like this.
1.created a host named webapp
2.under webapp i created a host named sitecollection

is that root site is must for hostnamed webpp
Justin SmithSr. System EngineerCommented:
What is the url to your root site?
What is the url to your host named site?
Did you add a host header in IIS for your host named site?
Pinemail11Author Commented:
i have followed like this
1 method
-------------
1.Created in 80 webapp
2.under that one root site exists which is not hostnamed "http://win-6kmb48i6lrh/'
3.created one more site collecton under webappwhich is hostnamed ."http://testsps01.cubicfuture.net/"

2nd method
1.created a webpp 6442 and given host header "http://cubicfuture.net
2.under that one hostnamed sitecoolection. "http://testaspsadmin.cubicfuture.net"

Not yet know which one is right
both yielded same result. no search results.I haven't used iis to name the webapp. from the sharepoint itself, when i create webapp , i gave host header.
Justin SmithSr. System EngineerCommented:
So the first web app, win-6k, should be working properly.  Since the root site doesn't use a host header, you shouldn't have to designate host headers for the host named sites in IIS.

The second web app, cubicfuture.net, probably won't work.  Since you used a host header "cubicfuture.net" for the root site, you would need to go into the site in IIS and specify host header for your host named sites (testaspsadmin.cubicfuture.net).

I'm curious on the first web app, if search is working on the root site?  if you go to http://win-6kmb48i6lrh do you get search results?

Do you know how Foundation search works?  Do you know that you can only search for items on the current site?  Meaning, you cant be on the win-6kmb site and search for items on the testsps01.cubicfuture site.
Pinemail11Author Commented:
yes i know the search related stuffs
on the first method the mentioned url is http://win-6kmb48i6lrh intranet site/default site.its not a hostnamed site.where search will work fine.
I have used couple of time managed path to map the url to internet, search works there also.

But when i used host named sitecollection under 80 or any other port ,search wont work. strange behavior but its true.
Justin SmithSr. System EngineerCommented:
I just tested this in my Foundation farm.  I have the following setup....

Web App root site - http://foundation1
Host named site - http://sf.smith.int

I created some content, and manually kicked off the crawl (stsadm -o spsearch -action startfullcrawl).  I waited a few minutes then did some searches.  Both sites show results correctly.

So, search does work on host named sites in Foundation.  Something is off in your config.  Are you using an AD account for the content access account?  
Pinemail11Author Commented:
here http://foundation1 is that your server name / host named.
Pinemail11Author Commented:
Dont know exactly what did the difference . The search worked in host named site collection.

wondering why even after full crawl, it took lot of time to show the result. Anyway result is poppingup.

Thanks for the support
Justin SmithSr. System EngineerCommented:
Loopback.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.