OWA URL login works with Public IP but not Domain Name

I'm have a bit of an issue here.  I can log into my OWA externally using http://publicIP/exchange but not with http://mail.mydomain.com/exchange.  My mail.mydomain.com resolves fine to the public IP, however, I'm still unable to use the mail.mydomain in place of the public IP.  How can I get this to work like I want it to?
KwodwoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TheTullCommented:
Does the mail.mydomain bring you to a different site on your server?  It sounds like that HTTP header may be assigned to another website or web directory on your server.
KwodwoAuthor Commented:
No the message I get is "Oops! Internet Explorer could not find mail.usvigers.com"
TheTullCommented:
Since you included the actual URL here I went ahead and tried it out and OWA comes up fine for me (I didn't try to log in obviously).  Are you testing from inside your network?  That error you received indicates that the DNS lookup failed.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

KwodwoAuthor Commented:
Yes I'm testing from inside.  Should an entry be added within the DNS lookup and exactly what?
KwodwoAuthor Commented:
Master,

I added the entry in my DNS lookup table and was able to pull you my OWA using the URL with my domain name, thanks much
TheTullCommented:
No problem, glad to hear you got it resolved!
kkareemCommented:
make sure mail.mydomain.com  command should be found on Public DNS  Server where you got Public IP
kkareemCommented:
sooory no command but A record

make sure mail.mydomain.com  A record  should be found on Public DNS  Server where you got Public IP

check by nslookup
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.