Windows 7 Pro Administrator is No Longer Administrator

I am still getting used to my new home computer Windows 7 Professional. I had three accounts on there Administrator, Myself and My Wife.  I had made myself an Administrator as I was doing a lot of Run As administrator installing software.
I did about windows 22 updates and now i can no longer Run As Administrator, nor am I an Administrator.  When I swithced to Administrator I got inf missing errors on the load and the Administrator is also no longer an Administator.
When I try changing account types to Administrator it is grayed out.  Not liking W7 right now.
How can i get Run as Administrator and Administrator righs back?
LVL 17
pjamAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

PowerEdgeTechIT ConsultantCommented:
I would attempt a System Restore back to a point before the update.  If you can't do it from any of the users, boot to a Windows 7 disk and do it from there.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
arnoldCommented:
The Administrator account might only be active in safe mode.
Did Administrator have a password.

I usually have two admin accounts just for a case like this.
Run5kCommented:
That's rather strange.  Simply installing Windows updates shouldn't change your account type from Administrator to Standard.  As a precaution, I would perform an antivirus scan as well as a quick scan with Malwarebytes.
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

pjamAuthor Commented:
Arnold,
Administrator did have a password but it didn't work.  Went in as myself and reset it.  Booted into Safe Mode, no go.
Poweredge, may need to try your suggestion although I have done a lot of work today and affected programs are listed at over 20 + going back to Dec 22nd.
I am uninstalling windows Security patches to see what happens there first.
Open to all thoughts,
Thanks
Run5kCommented:
If the previous suggestions don't work, you can utilize this utility disc to enable the built-in default Administrator account and reset the password.  It will also show you which accounts still have admin privileges.  Download the freeware ISO file from here:

Petter Nordahl-Hagen's Offline NT Password & Registry Editor
http://pogostick.net/~pnh/ntpasswd/

After you have burned that ISO to disc, boot up into the Linux environment and reset your password.  I have been using this utility to help people with their forgotten Windows passwords for over ten years, and unless the hard drive has actually been encrypted it has worked every time! Here is a comprehensive tutorial on how to utilize it:

http://pcsupport.about.com/od/toolsofthetrade/ss/ontpre-screenshot-guide.htm

http://pcsupport.about.com/od/toolsofthetrade/ss/ontpre-screenshot-guide-p2.htm

There are two important steps within that tutorial that warrant extra attention:

- When you reach the User Edit Menu stage of the process it's best to select "1" to Clear (blank) user password.  You can always change the password to something more secure after you successfully log into Windows with the blank password.

- When you reach Step FOUR: Writing back changes, you will be queried with About to write file(s) back! Do it? [n].  If you inadvertently pressed Enter on this screen the changes won’t go into effect.  You need to specifically type "y" first for the updates to be written to the operating system.
arnoldCommented:
There are tools that you can use ubcd4win which you can use to boot the system and perhaps the Administrator account got disabled.

use computer management when you are logged into the system to see whether the administrator account is still enabled or it might be locked out.
PowerEdgeTechIT ConsultantCommented:
The actual Administrator account is disabled by default ... did you Enable it?
pjamAuthor Commented:
Poweredge Tech,
Yes I am afraid i did when i first was setting it up
pjamAuthor Commented:
Run5k creating CD now from Pogostick
pjamAuthor Commented:
Run5k,
Linux boot stopped on:
pci  0000:04:00.0:  PCI bridge to [bus 05-05] (subtractive decode)

what is that about?
pjamAuthor Commented:
I tried boot nodrivers and boot nousb, stopped same place
Run5kCommented:
It sounds like you have encountered a rare situation where it doesn't like one of your components.  If you want to continue with this potential solution, I would keep trying the various boot options and take a closer look at the tutorial that I hyperlinked for potential options.
call4pchelpCommented:
Hi
TRY THIS, I TRIED, IT WORKED FOR ME.
    1- Join your home Pc with any domain Network FOR THE TIME BEING TO YOUR ADMIN RIGHTS
    2- Login as domain Admin in your PC just for creating a profile into it.
    3- ASSIGN LOCAL ADMIN RIGHTS BACK TO YOU by using domain admin account
    4- RESTART YOUR PC AND ENJOY WITH ADMIN RIGHTS.
   
pjamAuthor Commented:
Call4pchelp,
that would probably work, however at the current time we are not allowed to add W7 clients to our network.  Still 100% XP pro.
I will take it to local computer shop next week where they can do that, but was hoping to get it cleared up today.
I live in the country and use dialup so everything at home is sloooow.  Brought it in to work today to do updates, bad plan.

Run5k,
I have a Raid 1 setup, could that be causing the issue?

I ran MSE scan first thing this morning, running Malwarebytes Pro now

PowerEdgeTechIT ConsultantCommented:
If you have a spare PC and router/hub/switch, you can install 2008 on it, setup up a quick/basic domain, and do it ... if that method works at all.
pjamAuthor Commented:
Reran MSE, clean.
Malwarebytes clean.  Calling it a day, make that a year.  back Tuesday.
thanks for everyones help.
Hopefully I can get it straightened out.
Run5kCommented:
I have used the Offline NT Password & Registry Editor on machines with a RAID configuration before, but not recently.  I don't recall any extraordinary juggling.

"Brought it in to work today to do updates, bad plan." - pjam

Focusing on troubleshooting once again, based upon what you just said did you actually physically connect this machine up to your domain port in order to perform the updates?  If so, some networks and/or software suites will push configuration changes as soon as you acquire a domain IP address, even without actually joining the machine through Active Directory.
pjamAuthor Commented:
Run5k,
I did connect on the same network as the work domain.
No idea where to look for this change?
Local Policy?
I am at home now, I just did an IPconfig /all and I have  "CONNECTION-SPECIFIC DNS SUFFIX" related to the network sorta.  Not the Domain in use ow, but the old domain
arnoldCommented:
Unless the system PXE booted from the network and had everything reinstall, there is no way without matching credentials for data to be pushed onto an attached system.
The configuration can be to deny "unauthorized" systems from connecting 802.1x.
Run5kCommented:
Arnold, that's certainly true.  However, a workstation can still be affected by certain configuration changes.  For example, our Windows workstations with Symantec AntiVirus Corporate Edition pre-installed can still receive antivirus definition updates from the parent server as long as they had a valid IP address.

Pjam, as a simple "lesson learned" for future reference, I would definitely advise against hooking up your home computer to a domain network connection.  In your shoes, I would continue to see if I could get the Offline NT Password & Registry Editor to work.  
pjamAuthor Commented:
Run5k,
Just for clarigfication, I haven't forgotten the password I just cannot make anyone an administrator.
Will that do that for me.  I only see where it deletes the unknown pw and allws a new one to be created.
Still don't know why Linux wil not finish booting.  will try some more tomorrow.
Run5kCommented:
But, you haven't been able to login as the built-in default Administrator account because it is disabled, correct?  If that's the case, the Offline NT Password & Registry Editor disc will allow you to enable that account, and once you login with it you will then be able to modify another account to give if full admin privileges.
pjamAuthor Commented:
IRun5k,
It isn't disabled, it just is a Standard user for some unknown reason.  Although when you look at "Manage Accounts" they all say Username/Administrator/Password Protected.

I just created a new user account as an Administrator to see what would happen.  When logging in I get that same error:
"could not locate INF File 'C:\Windows\INF\msnetmtg.inf'" and this one:
"could not locate INF File 'C:\Windows\INF\msmsgs.inf'"

New account has Runs As Administrator, but not the ability to make the other accounts Administrator, still grayed out.
Run5kCommented:
This entire scenario is very unusual!

At this point, it might be prudent to follow the advice that PowerEdgeTech first provided and perform a System Restore back to the point before all of these problems first began:

How to Do a System Restore in Windows 7
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.