Exchange 2010 ActiveSync

Hello,
I am configuring Exchange 2010 "remote" features.  Exchange is published through TMG. The security certificate is locally issued.
Locally, Outlook and OWA work quite fine.  Remotely (over WAN), OWA works fine. ActiveSync, however, has a problem; inbound emails make it safe and sound to the smartphones. However, emails sent from smartphones never leave their Outbox!
On TMG, the listener to publish OWA is the same for AS.  The rules are almost identical too.  AS rule is a copy/paste of OWA rule, with the paths being modified to match destination virtual folders.
What is missing in here so that emails are not being sent from smartphones, regardless of model!

Regards
Yahya
Yba02Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
please read this article :

http://araihan.wordpress.com/2010/04/09/how-to-publish-exchange-activesync-in-forefront-tmg-2010/

review your configuration for activesync with TMG..

good luck
Yba02Author Commented:
Hello,
I have followed that link line by line.  I have even now configured Outlook Anywhere, in addition to EAS and OWA.  OA and OWA both work as a charm.  EAS, however, still fails to send emails.
On TMG logging, I can see the connection reaching TMG and going through to Exchange.  However, the website status reports "500 Internal server error."
I have checked the configuration of EAS feature in EMS and the virtual directory in IIS.
I am just not sure where else to dig.

Regards
Yahya
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
salam yahya keefk ya man ...
ok just give me a little time ..
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Yba02Author Commented:
Jordannet,
Ahlen abu samra, nshkr Allah.
I hope you can help

Best of the luck
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
yahya , ebn 3ami please run the following command and post the results here :


Get-ActiveSyncVirtualDirectory |fl

regards

Maen Abu-Tabanjeh
Amman - Jordan
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
ebn 3ami , please see here also , it maybe useful , w khaberni shoo bseer m3k .. 3ala fekra eza bt7b nkoon 3ala etesal bs roo7 3ala profili ana 7a6 el contact information w emili eb3tli ..

anyway just see this link :

http://www.sperrgebiet.org/2010/12/exchange-2010-activesync-http-500-internal-server-error-devicenotprovisioned_mbx/
Yba02Author Commented:
tslm li abu samra.
The link looks to be the fix.  Will give it a try tomorrow and let you know.

Regards
Yahya
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
ok 7abibi .. good luck ... w tesb7 3ala 5eer .. update me :)
Yba02Author Commented:
Hello,
None of the links resembled my case.
I have, however, done some digging and found an error in the log that reads "error: NotRunningAsLocalSystem".
I then went to the "Default Application Pool" and changed its identity from  ApplicationPoolIdentity to LocalSystem.  That also did not help.  There is, however, a new error now in the log that reads:  "error:System.Argument.Excpetion_As…"

Any clue?
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
for the error system.arguement exception .. please see here :

http://social.technet.microsoft.com/Forums/en/exchangesvrmobility/thread/321eae51-9cbd-4a5e-85c1-68d8f7b523c3

but am wondering to know about NotRunningAsLocalSystem.

where this error exist?
Yba02Author Commented:
It is in the wwwroot folder on Exchange server.
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
please go to application pool -> MSExchangeSyncAppPool -> check what is .NET version and piple line mode which is should be classic
Glen KnightCommented:
I would recommend using only a single rule.

If OWA is working, let's delete the other rule and modify the OWA rule.

Once you have deleted the second rule on the properties of the rule currently used for OWA under the Paths tab remove any entries and replace it with simply /*

This eliminates the second rule as a potential cause.

Once that's done if you could then goto https://www.testexchangeconnectivity.com/ and run the ActiveSync test.

Please post your findings
Yba02Author Commented:
Version is 2.0 and yes it is classic. But, EAS virtual directory is being served by the default application pool, not the MSExchangeSyncAppPool.

Did the twist in the rule but the test failed with this result almost everywhere:
Host autodiscover.mail.jeddahvalley.com couldn't be resolved in DNS InfoDomainNonexistent.

HTH
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
yba its should be MsEXchangeSyncAppPool , please change it , go to IIS default website -> point to Microsoft Active-Sync virtual Directory -> right click on it -> Manage Application -> advanced Settings ->
on application Pool , please choose MsExchnageSyncAppPool

restart IIS and try

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
autodiscover.mail.jeddahvalley.com? its wrong its must be autodiscover.jeddahvalley.com

go to powershell and run this command :

set-autodiscovervirtualDirectory -identitiy "Autodiscover (Default web site)" -externalURL https://autodiscover.jeddahvalley.com


good luck ya ibn 3ammi
Yba02Author Commented:
Hello,
Thank you all, it finally got rolling!
I have changed the pool to MsExchnageSyncAppPool BUT with piple line mode as Integrated.
Can I know what is the benefit of the AutoDiscover feature?

Regards
Yahya
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
Yaha , my friend MsExchangeSyncAppPool must be classic , autodiscover will let devices locally and outside discover your exchange server and embed settings to outlook or mail client , its very important without it outlook will not work fine
Yba02Author Commented:
I will have to check the settings of the pool pipe mode and will revert back accordingly.
For the autodiscover, it currently has its IP pointing to my hosting company server. I guess I will have to change the A record first before making the service available in my site. Please confirm.

Thanks
Maen Abu-TabanjehNetwork Administrator, Network ConsultantCommented:
for autodiscover yahya there is also need to have SRV record point to autodiscover ,  just go to domain management -> DNS , then create new record SRV its type is _TCP , its name must be autodiscover.domain.com and pointing the static IP address , this record automatically detected by Autodiscover services in email clients
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.