Samsung Bluray player BD-P1500 does not recognise firmware on CD or USB

Hi EE

I have a Samsung Bluray player BD-P1500 which does not appear to recognise firmware on CD or USB.  I have been at it for hours and burnt at least 5 CDs and to no avail.

I have downloaded the appropriate firnware from the Samsung website (ISO version and USB version)

With the USB, you just copy the .RUF file onto a blank stick and whack it into the USB port with no CD in the drive bay.  In my case, the bluray player only gets so far as to recognise  that a USB stick was plugged in, but sadly, it does nothing with the firmware therein.

With the CD, you download an ISO file, burn a CD using the ISO image creation s/w on a Mac or a PC,  which basically means you end up with the .RUF file on a CD.   I have tried burning the ISO on both Mac and PC but neither work.  I load the CD into the bluray player and get a "Disc can not be played" erro [sic]

Every video on this  subject on BooTube and everywhere else, shows the person happily putting the CD or USB stick in and presto, the CD / USB is recognised and the uploads and firmware updates begin.  But not here.

Note I do not have the means to connect the bluray player via the ethernet connection.

Can EE assist?  Why is the firmware not recognised by the bluray player on th CD and USB and how can I fix it to make it recognised so the firmware can be updated?

Many thanks

FH
Flying_High_71Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Brian PiercePhotographerCommented:
Have you tried inserting the disk/USB drive and then powering on the samsung with the disk/usb inserted ?
0
Flying_High_71Author Commented:
Yes.  To no avail.
0
Flying_High_71Author Commented:
The only workable option, short of getting the USB or CD working somehow, is to use the Network connection (ethernet) to Internet.  The only viable method of  connecting the BluRay player to the Internet is via a bridge in a notebook.  However bridging the bluray to the wireless network via a notebook (with Vista) might do the trick, if anybody knows how to do that.  My present attempts have failed.  
0
Introducing the "443 Security Simplified" Podcast

This new podcast puts you inside the minds of leading white-hat hackers and security researchers. Hosts Marc Laliberte and Corey Nachreiner turn complex security concepts into easily understood and actionable insights on the latest cyber security headlines and trends.

Flying_High_71Author Commented:
Hi EE

After much searching, I found the solution on another website (link at the end of this post).  Blessed be Monci123 who posted the following solution there.

Basically, to update the Firmware on the notebook, I have had to resort to sharing an internet connection on a notebook, and plugging in a network ethernet cable from the Bluray player to the Notebook, manually configuring the network connections on the notebook and blueray, and then using the System Update feature in the Bluray player.

This solution assumes you have a wireless enabled notebook that also has an ethernet connection (i.e. two networking devices) and of course a working wireless network.

NOTE: This did not involve bridging the two network connections.  If you bridge the connections this solution will not work for you.

Setting up the Notebook - Wireless Adapter
You have to enable ICS (internet connection sharing) in the laptop. To do this go to the wireless adapter properties (not the LAN, the WIRELESS adapter), advance tab and enable it.

Setting up the Notebook Ethernet Adapter
Go to the properties of the LAN (ethernet) adapter and change to a static IP. To change the IP, go to TCP IPv4 properties of the LAN adapter (network and sharing settings then change adapter settings). On the Laptop change the IP to 192.168.0.1 then subnet to 255.255.255.0 and leave blank or 0 all others.

Setting up the Bluray player
On the Bluray player you have to go to network settings and assign to the LAN IP 192.168.0.2, subnet to 255.255.255.0, default gateway to 192.168.0.1, DNS 192.168.0.1.

Finally click on System Update in the Bluray player and it should find the internet thru the ICS you just set up and start updating itself.

I think those were all the steps I used.

This is the link of the original post:
http://www.pchelpforum.com/network-help/87364-connecting-bluray-pc-thru-ethernet-port.html

This still does not answer why the CD and USB stick did not update the system, but we will see if this manual update makes a difference to this function.

FH
0
Flying_High_71Author Commented:
I spoke to Samsung Tech Support this morning.  

They could not understand why the update did not work via USB.  

They suggested that the CD did not work because the CD was not burnt with Nero.  Apparently "the BD-P1500 model is very pedantic about how the CDs are burnt" (to quote the Samsung Tech Suport person)

Also the System Update that you can do over the Internet directly from the machine via ethernet, may in fact be quite far behind the latest version of Firmware (again quoting the Tech rep)

The conclusion was that Samsung will send me a copy of the firmware on CD (presumably the latest version) and I will try that directly in the BD and see what comes of it.  They are suggesting at present that the new firmware update should hopefully fix the problem with the USB not being read.  

I will update this post once I have the updated via the CD, assuming it actually works.
0
Michael-BestCommented:
Try unpugging theSamsung Bluray player BD-P1500 from mains (AC) for 2 minutes plug in USB then AC mains then power on the Samsung Bluray player BD-P1500

Does it see USB and update firmware now?
0
Flying_High_71Author Commented:
Hi Michael-Best

In regard to my earlier comment, I received the CD from Samsung.  Suprisingly this CD was recognised and the firmware updated.  Strangely enough it updated itself twice with the same CD.  I then plugged in the USB key with the Samsung Firmware RUF file, but the Bluray player still did not read the contents.

Sadly turning off the power for two mins, plugging in the USB and then turning all the power back on did not work either.  The file is still not being read on the USB.  Is there any chance the USB is formatted the wrong way?  The file is in the root directory at present.
0
Michael-BestCommented:
Is there any chance the USB is formatted the wrong way?

Yes, or you have a corrupt or bad USB..can you try another USB? ( make sure its USB 2.0 or faster as the problem could be that your prersent USB is the slow 1.1 )
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Flying_High_71Author Commented:
Well, what do you know...

Looks like the problem might have been due to a USB 1.1 drive.  I redid the USB thing with a brand new USB key and presto it worked presumably 2.0 or higher.  Firmware was recognised.  Needless to say the Bluray was already up to date, due to the updated CD i received from Samsung, but at least for next time I will be able to use the USB key instead of the convoluted way I needed to go about updating it this time around. Thanks Michael-Best
0
Michael-BestCommented:
Glad to help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.